dev-util/netbeans: Migrate from LINGUAS to L10N.
authorUlrich Müller <ulm@gentoo.org>
Sat, 25 Jun 2016 00:43:40 +0000 (02:43 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sat, 25 Jun 2016 01:14:41 +0000 (03:14 +0200)
The following language codes are remapped to codes used by upstream:
ar: ar_EG,ar_SA
es: es,es_CO
gl: gl_ES
hi: hi_IN
id: in_ID
nl: nl_BE,nl_NL
ta: ta_IN
tl: fil_PH

Package-Manager: portage-2.3.0

dev-util/netbeans/netbeans-8.0.2.ebuild
dev-util/netbeans/netbeans-8.1.ebuild

index 67123069346064717754c3cb0440d6a3184b5451..4ad72ba9d06400dd0ce2ab148c832aa6cff6bd92 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -12,38 +12,38 @@ SOURCE_URL="http://download.netbeans.org/netbeans/8.0.2/final/zip/netbeans-8.0.2
 PATCHES_URL="https://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.0.2-build.xml.patch.bz2"
 L10N_URL="https://dev.gentoo.org/~fordfrog/distfiles/netbeans-l10n-8.0.1-20141110.tar.bz2"
 ALL_URLS="${SOURCE_URL} ${PATCHES_URL} ${L10N_URL}"
-SRC_URI="linguas_af? ( ${ALL_URLS} )
-       linguas_ar? ( ${ALL_URLS} )
-       linguas_bg? ( ${ALL_URLS} )
-       linguas_ca? ( ${ALL_URLS} )
-       linguas_cs? ( ${ALL_URLS} )
-       linguas_de? ( ${ALL_URLS} )
-       linguas_el? ( ${ALL_URLS} )
-       linguas_es? ( ${ALL_URLS} )
-       linguas_fr? ( ${ALL_URLS} )
-       linguas_gl? ( ${ALL_URLS} )
-       linguas_hi_IN? ( ${ALL_URLS} )
-       linguas_id? ( ${ALL_URLS} )
-       linguas_it? ( ${ALL_URLS} )
-       linguas_ja? ( ${ALL_URLS} )
-       linguas_ko? ( ${ALL_URLS} )
-       linguas_lt? ( ${ALL_URLS} )
-       linguas_nl? ( ${ALL_URLS} )
-       linguas_pl? ( ${ALL_URLS} )
-       linguas_pt_BR? ( ${ALL_URLS} )
-       linguas_pt_PT? ( ${ALL_URLS} )
-       linguas_ro? ( ${ALL_URLS} )
-       linguas_ru? ( ${ALL_URLS} )
-       linguas_si? ( ${ALL_URLS} )
-       linguas_sq? ( ${ALL_URLS} )
-       linguas_sr? ( ${ALL_URLS} )
-       linguas_sv? ( ${ALL_URLS} )
-       linguas_ta_IN? ( ${ALL_URLS} )
-       linguas_tl? ( ${ALL_URLS} )
-       linguas_tr? ( ${ALL_URLS} )
-       linguas_vi? ( ${ALL_URLS} )
-       linguas_zh_CN? ( ${ALL_URLS} )
-       linguas_zh_TW? ( ${ALL_URLS} )
+SRC_URI="l10n_af? ( ${ALL_URLS} )
+       l10n_ar? ( ${ALL_URLS} )
+       l10n_bg? ( ${ALL_URLS} )
+       l10n_ca? ( ${ALL_URLS} )
+       l10n_cs? ( ${ALL_URLS} )
+       l10n_de? ( ${ALL_URLS} )
+       l10n_el? ( ${ALL_URLS} )
+       l10n_es? ( ${ALL_URLS} )
+       l10n_fr? ( ${ALL_URLS} )
+       l10n_gl? ( ${ALL_URLS} )
+       l10n_hi? ( ${ALL_URLS} )
+       l10n_id? ( ${ALL_URLS} )
+       l10n_it? ( ${ALL_URLS} )
+       l10n_ja? ( ${ALL_URLS} )
+       l10n_ko? ( ${ALL_URLS} )
+       l10n_lt? ( ${ALL_URLS} )
+       l10n_nl? ( ${ALL_URLS} )
+       l10n_pl? ( ${ALL_URLS} )
+       l10n_pt-BR? ( ${ALL_URLS} )
+       l10n_pt-PT? ( ${ALL_URLS} )
+       l10n_ro? ( ${ALL_URLS} )
+       l10n_ru? ( ${ALL_URLS} )
+       l10n_si? ( ${ALL_URLS} )
+       l10n_sq? ( ${ALL_URLS} )
+       l10n_sr? ( ${ALL_URLS} )
+       l10n_sv? ( ${ALL_URLS} )
+       l10n_ta? ( ${ALL_URLS} )
+       l10n_tl? ( ${ALL_URLS} )
+       l10n_tr? ( ${ALL_URLS} )
+       l10n_vi? ( ${ALL_URLS} )
+       l10n_zh-CN? ( ${ALL_URLS} )
+       l10n_zh-TW? ( ${ALL_URLS} )
 "
 LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
 KEYWORDS="amd64 x86"
@@ -63,40 +63,40 @@ IUSE_NETBEANS_MODULES="
        +netbeans_modules_profiler
        netbeans_modules_webcommon
        +netbeans_modules_websvccommon"
-IUSE_LINGUAS="
-       linguas_af
-       linguas_ar
-       linguas_bg
-       linguas_ca
-       linguas_cs
-       linguas_de
-       linguas_el
-       linguas_es
-       linguas_fr
-       linguas_gl
-       linguas_hi_IN
-       linguas_id
-       linguas_it
-       linguas_ja
-       linguas_ko
-       linguas_lt
-       linguas_nl
-       linguas_pl
-       linguas_pt_BR
-       linguas_pt_PT
-       linguas_ro
-       linguas_ru
-       linguas_si
-       linguas_sq
-       linguas_sr
-       linguas_sv
-       linguas_ta_IN
-       linguas_tl
-       linguas_tr
-       linguas_vi
-       linguas_zh_CN
-       linguas_zh_TW"
-IUSE="doc ${IUSE_NETBEANS_MODULES} ${IUSE_LINGUAS}"
+IUSE_L10N="
+       l10n_af
+       l10n_ar
+       l10n_bg
+       l10n_ca
+       l10n_cs
+       l10n_de
+       l10n_el
+       l10n_es
+       l10n_fr
+       l10n_gl
+       l10n_hi
+       l10n_id
+       l10n_it
+       l10n_ja
+       l10n_ko
+       l10n_lt
+       l10n_nl
+       l10n_pl
+       l10n_pt-BR
+       l10n_pt-PT
+       l10n_ro
+       l10n_ru
+       l10n_si
+       l10n_sq
+       l10n_sr
+       l10n_sv
+       l10n_ta
+       l10n_tl
+       l10n_tr
+       l10n_vi
+       l10n_zh-CN
+       l10n_zh-TW"
+IUSE="doc ${IUSE_NETBEANS_MODULES} ${IUSE_L10N}"
 S="${WORKDIR}"
 
 DEPEND="virtual/jdk:1.7
@@ -126,22 +126,20 @@ JAVA_PKG_BSFIX="off"
 NBLOCALES=""
 
 pkg_setup() {
-       for lingua in ${IUSE_LINGUAS} ; do
-               local lang=${lingua/linguas_/}
+       for lingua in ${IUSE_L10N} ; do
+               local lang=${lingua/l10n_/}
+               lang=${lang/-/_}
 
-               if [[ "${lang}" = "ar" ]] ; then
-                       lang="ar_EG,ar_SA"
-               elif [[ "${lang}" = "es" ]] ; then
-                       lang="es,es_CO"
-               elif [[ "${lang}" = "gl" ]] ; then
-                       lang="gl_ES"
-               elif [[ "${lang}" = "id" ]] ; then
-                       lang="in_ID"
-               elif [[ "${lang}" = "nl" ]] ; then
-                       lang="nl_BE,nl_NL"
-               elif [[ "${lang}" = "tl" ]] ; then
-                       lang="fil_PH"
-               fi
+               case ${lang} in
+                       ar) lang="ar_EG,ar_SA" ;;
+                       es) lang="es,es_CO"    ;;
+                       gl) lang="gl_ES"       ;;
+                       hi) lang="hi_IN"       ;;
+                       id) lang="in_ID"       ;;
+                       nl) lang="nl_BE,nl_NL" ;;
+                       ta) lang="ta_IN"       ;;
+                       tl) lang="fil_PH"      ;;
+               esac
 
                if use ${lingua} ; then
                        if [ -z "${NBLOCALES}" ] ; then
@@ -232,32 +230,27 @@ pkg_postinst() {
                einfo "${PN}-${SLOT} --locale pt:BR"
        fi
 
-       if use linguas_ar ; then
+       if use l10n_ar ; then
                einfo
                einfo "You selected Arabic locale so you can choose either ar:EG or ar:SA variant."
        fi
 
-       if use linguas_es ; then
+       if use l10n_es ; then
                einfo
                einfo "You selected Spanish locale so you can choose either es or es:CO variant."
        fi
 
-       if use linguas_gl ; then
-               einfo
-               einfo "You selected Galician locale which has locale code gl:ES in Netbeans."
-       fi
-
-       if use linguas_id ; then
+       if use l10n_id ; then
                einfo
                einfo "You selected Indonesian locale which has locale code in:ID in Netbeans."
        fi
 
-       if use linguas_nl ; then
+       if use l10n_nl ; then
                einfo
                einfo "You selected Dutch locale so you can choose either nl:BE or nl:NL variant."
        fi
 
-       if use linguas_tl ; then
+       if use l10n_tl ; then
                einfo
                einfo "You selected Tagalog locale which has for Filipino locale code fil:PH in Netbeans."
        fi
index 396b5dec33772602b553fe69b7ccac56fc72ce7e..c302477f93fa744d5764666a7fa8bc3abc3e64c4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -12,41 +12,38 @@ SOURCE_URL="http://download.netbeans.org/netbeans/8.1/final/zip/netbeans-8.1-201
 PATCHES_URL="http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.1-build.xml.patch.bz2"
 L10N_URL="http://dev.gentoo.org/~fordfrog/distfiles/netbeans-l10n-8.1-20151105.tar.bz2"
 ALL_URLS="${SOURCE_URL} ${PATCHES_URL} ${L10N_URL}"
-SRC_URI="linguas_af? ( ${ALL_URLS} )
-       linguas_ar? ( ${ALL_URLS} )
-       linguas_ar_SA? ( ${ALL_URLS} )
-       linguas_bg? ( ${ALL_URLS} )
-       linguas_ca? ( ${ALL_URLS} )
-       linguas_cs? ( ${ALL_URLS} )
-       linguas_de? ( ${ALL_URLS} )
-       linguas_el? ( ${ALL_URLS} )
-       linguas_es? ( ${ALL_URLS} )
-       linguas_es_CO? ( ${ALL_URLS} )
-       linguas_fil? ( ${ALL_URLS} )
-       linguas_fr? ( ${ALL_URLS} )
-       linguas_gl? ( ${ALL_URLS} )
-       linguas_hi_IN? ( ${ALL_URLS} )
-       linguas_id_ID? ( ${ALL_URLS} )
-       linguas_it? ( ${ALL_URLS} )
-       linguas_ja? ( ${ALL_URLS} )
-       linguas_ko? ( ${ALL_URLS} )
-       linguas_lt? ( ${ALL_URLS} )
-       linguas_nl_BE? ( ${ALL_URLS} )
-       linguas_nl_NL? ( ${ALL_URLS} )
-       linguas_pl? ( ${ALL_URLS} )
-       linguas_pt_BR? ( ${ALL_URLS} )
-       linguas_pt_PT? ( ${ALL_URLS} )
-       linguas_ro? ( ${ALL_URLS} )
-       linguas_ru? ( ${ALL_URLS} )
-       linguas_si? ( ${ALL_URLS} )
-       linguas_sq? ( ${ALL_URLS} )
-       linguas_sr? ( ${ALL_URLS} )
-       linguas_sv? ( ${ALL_URLS} )
-       linguas_ta_IN? ( ${ALL_URLS} )
-       linguas_tr? ( ${ALL_URLS} )
-       linguas_vi? ( ${ALL_URLS} )
-       linguas_zh_CN? ( ${ALL_URLS} )
-       linguas_zh_TW? ( ${ALL_URLS} )
+SRC_URI="l10n_af? ( ${ALL_URLS} )
+       l10n_ar? ( ${ALL_URLS} )
+       l10n_bg? ( ${ALL_URLS} )
+       l10n_ca? ( ${ALL_URLS} )
+       l10n_cs? ( ${ALL_URLS} )
+       l10n_de? ( ${ALL_URLS} )
+       l10n_el? ( ${ALL_URLS} )
+       l10n_es? ( ${ALL_URLS} )
+       l10n_fr? ( ${ALL_URLS} )
+       l10n_gl? ( ${ALL_URLS} )
+       l10n_hi? ( ${ALL_URLS} )
+       l10n_id? ( ${ALL_URLS} )
+       l10n_it? ( ${ALL_URLS} )
+       l10n_ja? ( ${ALL_URLS} )
+       l10n_ko? ( ${ALL_URLS} )
+       l10n_lt? ( ${ALL_URLS} )
+       l10n_nl? ( ${ALL_URLS} )
+       l10n_pl? ( ${ALL_URLS} )
+       l10n_pt-BR? ( ${ALL_URLS} )
+       l10n_pt-PT? ( ${ALL_URLS} )
+       l10n_ro? ( ${ALL_URLS} )
+       l10n_ru? ( ${ALL_URLS} )
+       l10n_si? ( ${ALL_URLS} )
+       l10n_sq? ( ${ALL_URLS} )
+       l10n_sr? ( ${ALL_URLS} )
+       l10n_sv? ( ${ALL_URLS} )
+       l10n_ta? ( ${ALL_URLS} )
+       l10n_tl? ( ${ALL_URLS} )
+       l10n_tr? ( ${ALL_URLS} )
+       l10n_vi? ( ${ALL_URLS} )
+       l10n_zh-CN? ( ${ALL_URLS} )
+       l10n_zh-TW? ( ${ALL_URLS} )
 "
 LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
 KEYWORDS="~amd64 ~x86"
@@ -66,43 +63,40 @@ IUSE_NETBEANS_MODULES="
        +netbeans_modules_profiler
        netbeans_modules_webcommon
        +netbeans_modules_websvccommon"
-IUSE_LINGUAS="
-       linguas_af
-       linguas_ar
-       linguas_ar_SA
-       linguas_bg
-       linguas_ca
-       linguas_cs
-       linguas_de
-       linguas_el
-       linguas_es
-       linguas_es_CO
-       linguas_fil
-       linguas_fr
-       linguas_gl
-       linguas_hi_IN
-       linguas_id_ID
-       linguas_it
-       linguas_ja
-       linguas_ko
-       linguas_lt
-       linguas_nl_BE
-       linguas_nl_NL
-       linguas_pl
-       linguas_pt_BR
-       linguas_pt_PT
-       linguas_ro
-       linguas_ru
-       linguas_si
-       linguas_sq
-       linguas_sr
-       linguas_sv
-       linguas_ta_IN
-       linguas_tr
-       linguas_vi
-       linguas_zh_CN
-       linguas_zh_TW"
-IUSE="doc ${IUSE_NETBEANS_MODULES} ${IUSE_LINGUAS}"
+IUSE_L10N="
+       l10n_af
+       l10n_ar
+       l10n_bg
+       l10n_ca
+       l10n_cs
+       l10n_de
+       l10n_el
+       l10n_es
+       l10n_fr
+       l10n_gl
+       l10n_hi
+       l10n_id
+       l10n_it
+       l10n_ja
+       l10n_ko
+       l10n_lt
+       l10n_nl
+       l10n_pl
+       l10n_pt-BR
+       l10n_pt-PT
+       l10n_ro
+       l10n_ru
+       l10n_si
+       l10n_sq
+       l10n_sr
+       l10n_sv
+       l10n_ta
+       l10n_tl
+       l10n_tr
+       l10n_vi
+       l10n_zh-CN
+       l10n_zh-TW"
+IUSE="doc ${IUSE_NETBEANS_MODULES} ${IUSE_L10N}"
 S="${WORKDIR}"
 
 DEPEND=">=virtual/jdk-1.7
@@ -132,20 +126,20 @@ JAVA_PKG_BSFIX="off"
 NBLOCALES=""
 
 pkg_setup() {
-       for lingua in ${IUSE_LINGUAS} ; do
-               local lang=${lingua/linguas_/}
-
-               if [[ "${lang}" = "ar" ]] ; then
-                       lang="ar_EG,ar_SA"
-               elif [[ "${lang}" = "es" ]] ; then
-                       lang="es,es_CO"
-               elif [[ "${lang}" = "fil" ]] ; then
-                       lang="fil_PH"
-               elif [[ "${lang}" = "gl" ]] ; then
-                       lang="gl_ES"
-               elif [[ "${lang}" = "id_ID" ]] ; then
-                       lang="in_ID"
-               fi
+       for lingua in ${IUSE_L10N} ; do
+               local lang=${lingua/l10n_/}
+               lang=${lang/-/_}
+
+               case ${lang} in
+                       ar) lang="ar_EG,ar_SA" ;;
+                       es) lang="es,es_CO"    ;;
+                       gl) lang="gl_ES"       ;;
+                       hi) lang="hi_IN"       ;;
+                       id) lang="in_ID"       ;;
+                       nl) lang="nl_BE,nl_NL" ;;
+                       ta) lang="ta_IN"       ;;
+                       tl) lang="fil_PH"      ;;
+               esac
 
                if use ${lingua} ; then
                        if [ -z "${NBLOCALES}" ] ; then
@@ -236,18 +230,28 @@ pkg_postinst() {
                einfo "${PN}-${SLOT} --locale pt:BR"
        fi
 
-       if use linguas_ar ; then
+       if use l10n_ar ; then
                einfo
                einfo "You selected Arabic locale so you can choose either ar:EG or ar:SA variant."
        fi
 
-       if use linguas_es ; then
+       if use l10n_es ; then
                einfo
                einfo "You selected Spanish locale so you can choose either es or es:CO variant."
        fi
 
-       if use linguas_id_ID ; then
+       if use l10n_id ; then
                einfo
                einfo "You selected Indonesian locale which has locale code in:ID in Netbeans."
        fi
+
+       if use l10n_nl ; then
+               einfo
+               einfo "You selected Dutch locale so you can choose either nl:BE or nl:NL variant."
+       fi
+
+       if use l10n_tl ; then
+               einfo
+               einfo "You selected Tagalog locale which has for Filipino locale code fil:PH in Netbeans."
+       fi
 }