ros-meta/perception_pcl: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 11:51:40 +0000 (13:51 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 11:52:23 +0000 (13:52 +0200)
Package-Manager: portage-2.2.21

ros-meta/perception_pcl/Manifest [new file with mode: 0644]
ros-meta/perception_pcl/metadata.xml [new file with mode: 0644]
ros-meta/perception_pcl/perception_pcl-1.3.0.ebuild [new file with mode: 0644]
ros-meta/perception_pcl/perception_pcl-9999.ebuild [new file with mode: 0644]

diff --git a/ros-meta/perception_pcl/Manifest b/ros-meta/perception_pcl/Manifest
new file mode 100644 (file)
index 0000000..112207c
--- /dev/null
@@ -0,0 +1 @@
+DIST perception_pcl-1.3.0.tar.gz 66060 SHA256 c9b01170ca92240e81113ddd880505f54a08084b67edfe450363499a828b6586 SHA512 203fcc2c1d71bfd6890c4e5664b29404bea666f277eee88d4725766bc21fb7aac3aced467be2f3352e3c172a7175ab8c4124d5652dad03d6a7b661748ec94175 WHIRLPOOL 7e18df41d3f61d1c6f7fa29d3933d1deeaadeb493416ab128df7c6ea9578074771b069c047ad6f71cb46202e4b5e5f6bdcbfbe72519450aeb4a5ab1547378a00
diff --git a/ros-meta/perception_pcl/metadata.xml b/ros-meta/perception_pcl/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/perception_pcl/perception_pcl-1.3.0.ebuild b/ros-meta/perception_pcl/perception_pcl-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..7f0fcfe
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library) ROS interface stack"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/pcl_ros
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/perception_pcl/perception_pcl-9999.ebuild b/ros-meta/perception_pcl/perception_pcl-9999.ebuild
new file mode 100644 (file)
index 0000000..7f0fcfe
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library) ROS interface stack"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/pcl_ros
+"
+DEPEND="${RDEPEND}"