sys-apps/less: Bump to version 560
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 7 May 2020 13:14:16 +0000 (15:14 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 7 May 2020 14:06:53 +0000 (16:06 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/less/Manifest
sys-apps/less/less-560.ebuild [new file with mode: 0644]

index c9bcb04ec5dce215b3e2878165e1a7eceded2d62..74c0df4045f535ca644ac31a717606ceca27783a 100644 (file)
@@ -1,3 +1,4 @@
 DIST less-551.tar.gz 347007 BLAKE2B 033a043340f888616c8342703597b9232ae1c8e62775d3ee0187599c3d9d9824fdbc7543ca90cdc535b2077a8bcbefe322887ad29289620191d8cf6ff86ddd04 SHA512 ef5296b9ebd72f83c05cad8a0f7a5eec2290e9b358ee725e09e8541bd95f94c0e14ea22aa04b287a0654079338eaeae813f2235b8e9f819fbbc9040dd65a9585
 DIST less-556.tar.gz 335019 BLAKE2B 7e0152c96751451626b3ff614b40f3c4d4e8ecd4b01e4a47ae443c3e7d83a1fc3fae8c21946626eda596631b0c6ca965113272fbea40389f20109e3125fa93e3 SHA512 a7235fae97414c7acb287b334dd071232d682e01627eb9a25f6a7ea72c58914f141657e067944f9672aa9f614012848e134e8d02dfb34892d20384f5e596bd21
 DIST less-557.tar.gz 335142 BLAKE2B 1c8645d70b1eb6d6d7f88c62ae77cce64e39262b32608cc4a27c0c8a79a2f84506ae41f76bd8eceeac8d294192f8d9006b7ab503482b2a4cdd6a2837ab187851 SHA512 5d82942d90c098fe81bf070e77c5d388eef83eaf4f4c48bc1ea6c0f718b04d09cc1071448e0f4cdf443872842d8ace9339036e77ee8a0baf6f4d02e91e87848b
+DIST less-560.tar.gz 335124 BLAKE2B e65ad2f0e99b633b8be59027b1b97cf3613ae4d2d1dfa2ca9ebbee71bdbe07fcee127f2554122789726def8a5137cf76a850a4767f005b168be714fe11f0da9d SHA512 8dd39e7bdf8274548e70d27ba1ac863c5957646c8fdd708fd87bffb204149252e4bbd8839969b507ba34f2d2d712bd0689d4fd5fb944bec1e40885bbcf06f40d
diff --git a/sys-apps/less/less-560.ebuild b/sys-apps/less/less-560.ebuild
new file mode 100644 (file)
index 0000000..375e258
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+       >=sys-libs/ncurses-5.2:0=
+       pcre? ( dev-libs/libpcre2 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+       export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+       local myeconfargs=(
+               --with-regex=$(usex pcre pcre2 posix)
+               --with-editor="${EPREFIX}"/usr/libexec/editor
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       newbin "${FILESDIR}"/lesspipe.sh lesspipe
+       newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+       if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+               elog "The lesspipe.sh symlink has been dropped.  If you are still setting"
+               elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+               elog "Colorization support has been dropped.  If you want that, check out"
+               elog "the new app-text/lesspipe package."
+       fi
+}