dev-php/phpunit: Revbump to stable for dependency change
authorBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 15:50:09 +0000 (10:50 -0500)
committerBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 15:51:13 +0000 (10:51 -0500)
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/phpunit/phpunit-5.7.15-r1.ebuild [deleted file]
dev-php/phpunit/phpunit-5.7.15-r3.ebuild [moved from dev-php/phpunit/phpunit-5.7.15-r2.ebuild with 84% similarity]

diff --git a/dev-php/phpunit/phpunit-5.7.15-r1.ebuild b/dev-php/phpunit/phpunit-5.7.15-r1.ebuild
deleted file mode 100644 (file)
index f6e1e66..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A PHP Unit Testing framework"
-HOMEPAGE="http://phpunit.de"
-SRC_URI="https://github.com/sebastianbergmann/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE=""
-
-RDEPEND="dev-php/fedora-autoloader
-       >=dev-php/File_Iterator-1.4.0
-       !>=dev-php/File_Iterator-2.0
-       >=dev-php/Text_Template-1.2.0
-       !>=dev-php/Text_Template-2.0
-       >=dev-php/PHP_CodeCoverage-4.0.4
-       !>=dev-php/PHP_CodeCoverage-5.0
-       >=dev-php/PHP_Timer-1.0.6
-       !>=dev-php/PHP_Timer-2.0
-       <dev-php/myclabs-deepcopy-2.0
-       <dev-php/phpspec-prophecy-2.0
-       <dev-php/phpunit-mock-objects-4.0
-       <dev-php/sebastian-comparator-2.0
-       <dev-php/sebastian-diff-2.0
-       <dev-php/sebastian-environment-3.0
-       <dev-php/sebastian-exporter-3.0
-       <dev-php/sebastian-global-state-2.0
-       <dev-php/sebastian-object-enumerator-3.0
-       <dev-php/sebastian-resource-operations-2.0
-       <dev-php/sebastian-version-3.0
-       <dev-php/symfony-yaml-4.0
-       || (
-               dev-lang/php:5.6[cli,json,unicode,xml]
-               dev-lang/php:7.0[cli,json,unicode,xml]
-               dev-lang/php:7.1[cli,json,unicode,xml]
-       )"
-
-src_install() {
-       insinto /usr/share/php/PHPUnit
-       doins -r src/*
-       insinto /usr/share/php/PHPUnit/vendor
-       doins "${FILESDIR}/autoload.php"
-       exeinto /usr/share/php/PHPUnit
-       doexe phpunit
-       dosym ../share/php/PHPUnit/phpunit /usr/bin/phpunit
-}
-
-pkg_postinst() {
-       elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
-       elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
-}
similarity index 84%
rename from dev-php/phpunit/phpunit-5.7.15-r2.ebuild
rename to dev-php/phpunit/phpunit-5.7.15-r3.ebuild
index 83f63fe1edb1e84b8238bb880f470e39c2ace8d8..a3a224587d3d8faae0ce0a3d788935d1889ce8c1 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 DESCRIPTION="A PHP Unit Testing framework"
 HOMEPAGE="http://phpunit.de"
@@ -9,7 +9,7 @@ SRC_URI="https://github.com/sebastianbergmann/${PN}/archive/${PV}.tar.gz -> ${P}
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
 IUSE=""
 
 RDEPEND="dev-php/fedora-autoloader
@@ -34,9 +34,7 @@ RDEPEND="dev-php/fedora-autoloader
        <dev-php/sebastian-version-3.0
        <dev-php/symfony-yaml-4.0
        || (
-               dev-lang/php:5.6[cli,json,unicode,xml]
-               dev-lang/php:7.0[cli,json,unicode,xml]
-               dev-lang/php:7.1[cli,json,unicode,xml]
+               dev-lang/php:7.2[cli(-),json(-),unicode(-),xml(-)]
        )"
 
 src_install() {