dev-libs/pigpio: new ebuild version 68
authorDaniel Kenzelmann <gentoo@k8n.de>
Wed, 19 Jun 2019 19:11:22 +0000 (21:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 18:26:34 +0000 (20:26 +0200)
New ebuild for dev-libs/pigpio-68, cleanup, add EPREFIX

Signed-off-by: Daniel Kenzelmann <gentoo@k8n.de>
Closes: https://github.com/gentoo/gentoo/pull/12252
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/pigpio/Manifest
dev-libs/pigpio/pigpio-68.ebuild [new file with mode: 0644]

index ed15ca2500f3e99bb796552754221cc0bb24cdfd..9928f29679a28bbb697818553fc0b3b0e815e48f 100644 (file)
@@ -1 +1,2 @@
 DIST pigpio-67.tar.gz 369268 BLAKE2B a9d59369f5eed4b733e0e5c0e85013a132e55ff63a2393d79a3fb52d1fcb2513559d4dfeea84c4842d6281936b6e116bd81cd63e4542bbcffaf813ee356ee0d1 SHA512 9792f8402ee0dd204f4a975ab0513099a1fe3d398a28b766f412c08d7908e8e307de4cc92b2a2519b6484f15a043bd40008b7707486015c08bda5f97b1e7e00b
+DIST pigpio-68.tar.gz 371251 BLAKE2B c0118854d18ce158a3d5c96380289cc8bc68f35f72ce28f207dfbb827f97f538acd82cec2af11590e59985b77ef08834d55b3ac7578e1f6b6d1a0b5d5d594632 SHA512 125364eab9dd33c39fda148c6018679ac91b099914d7f0c6362f61566a9c957065189ace03ad4668b29f25d4d542b81d42c0befe0712867b48977b755dc03edc
diff --git a/dev-libs/pigpio/pigpio-68.ebuild b/dev-libs/pigpio/pigpio-68.ebuild
new file mode 100644 (file)
index 0000000..ab323e8
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1 systemd toolchain-funcs
+
+DESCRIPTION="A library for the Raspberry which allows control of the GPIOs"
+HOMEPAGE="http://abyz.me.uk/rpi/pigpio/index.html"
+SRC_URI="https://github.com/joan2937/pigpio/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+       eapply "${FILESDIR}/${PN}-67-makefile.patch"
+       eapply_user
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" STRIP=: STRIPLIB=: SIZE=:
+       use python && distutils-r1_src_compile
+}
+
+src_install() {
+       emake DESTDIR="${D}" LDCONFIG=: PYTHON2=: PYTHON3=: \
+               libdir="$(get_libdir)" prefix="${EPREFIX}/usr" \
+               mandir="${EPREFIX}/usr/share/man" install
+       einstalldocs
+       newinitd "${FILESDIR}"/pigpiod.initd pigpiod
+       newconfd "${FILESDIR}"/pigpiod.confd pigpiod
+       systemd_newunit "${FILESDIR}"/pigpiod.systemd pigpiod.service
+       use python && distutils-r1_src_install
+}