sci-astronomy/pyephem: Drop 3.7.5.3 and 3.7.6.0 (r0)
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 22:49:52 +0000 (23:49 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 22:51:19 +0000 (23:51 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-astronomy/pyephem/Manifest
sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild [deleted file]
sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild [deleted file]

index 3b36919729c30ddbd78ae3a2ecbb6411c783782d..cbf430afc0cea1b795e4689bf99004f7ec135768 100644 (file)
@@ -1,2 +1 @@
-DIST pyephem-3.7.5.3.tar.gz 735112 BLAKE2B 0edac4210c6ab745e64641d21f053fbd67a6e3841d1eb6b3b06bd5d4fcff0b6a1e1dc1634d8608e990eb6e588d030cc6a67115ebfd7bbefeb8f5ce219ae3ca1b SHA512 a61b6a19c35c10ee9d4eba72cb0e6b9446076a3943be58dfd5e084bc9ab09dc70f2ee335ba5f0ef9d9d4d34a461bf4b9ddd57dae50d2e8a8f565d411e47f2908
 DIST pyephem-3.7.6.0.tar.gz 739561 BLAKE2B a8129632514940e6d786dcc50d2dd0bd1fff2b76b9d59f88820c93cce3400f9b15c4f7418bc778ee5ad60a8909a970aaea5df62c5192fcb71f822b97abc0dc4f SHA512 c3013ef943c0e1e2c30bba6f72912efb100b4c8c45904b7d6d7ba73d8b741564793a6e538117eb88abb824c93c874e2c955de734418ebd2370888718a149c9a8
diff --git a/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild b/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild
deleted file mode 100644 (file)
index 31682fc..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Astronomical routines for the python programming language"
-HOMEPAGE="https://rhodesmill.org/pyephem/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-DEPEND="
-       doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-src_prepare() {
-       # don't install rst files
-       sed -i -e "s:'doc/\*\.rst',::" setup.py || die
-       distutils-r1_src_prepare
-}
-
-src_compile() {
-       distutils-r1_src_compile
-       if use doc; then
-               PYTHONPATH=. emake -C ephem/doc html
-       fi
-}
-
-python_test() {
-       if [[ ${PYTHON_ABI} == "2.7" ]]; then
-               PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
-                       ${EPYTHON} -m unittest discover -s src/ephem
-       else
-               PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
-                       unit2 discover -s src/ephem
-       fi
-}
-
-src_install() {
-       distutils-r1_src_install
-       use doc && dohtml -r ephem/doc/_build/html/*
-
-       delete_tests() {
-               rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
-       }
-       python_foreach_impl delete_tests
-}
diff --git a/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild b/sci-astronomy/pyephem/pyephem-3.7.6.0.ebuild
deleted file mode 100644 (file)
index 8dcbafe..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Astronomical routines for the python programming language"
-HOMEPAGE="https://rhodesmill.org/pyephem/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-DEPEND="doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-src_prepare() {
-       # don't install rst files by dfefault
-       sed -i -e "s:'doc/\*\.rst',::" setup.py || die
-       distutils-r1_src_prepare
-}
-
-src_compile() {
-       distutils-r1_src_compile
-       if use doc; then
-               PYTHONPATH=. emake -C ephem/doc html
-       fi
-}
-
-python_test() {
-       if [[ ${PYTHON_ABI} == "2.7" ]]; then
-               PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
-                       ${EPYTHON} -m unittest discover -s ephem
-       else
-               PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
-                       unit2 discover -s ephem
-       fi
-}
-
-src_install() {
-       use doc && HTML_DOCS=( ephem/doc/_build/html/. )
-       distutils-r1_src_install
-
-       delete_tests() {
-               rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
-       }
-       python_foreach_impl delete_tests
-}