media-tv/tvheadend: Apply GLEP 81 and move default config directory
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 10 May 2020 22:15:26 +0000 (23:15 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 10 May 2020 22:15:26 +0000 (23:15 +0100)
This moves the HOME directory for the tvheadend user, and hence the
config directory, from /etc/tvheadend to /var/lib/tvheadend. The
daemon does not check the HOME directory so no change is effectively
made until TVHEADEND_CONFIG in /etc/conf.d/tvheadend is updated.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
media-tv/tvheadend/files/tvheadend.confd
media-tv/tvheadend/tvheadend-4.2.8-r1.ebuild [moved from media-tv/tvheadend/tvheadend-4.2.8.ebuild with 83% similarity]
media-tv/tvheadend/tvheadend-9999.ebuild

index 8be4a5dadce9761716d225c821ded658e8216124..bac19ece3ac1304273642cdc1660343b81e9c7ca 100644 (file)
@@ -8,7 +8,7 @@ TVHEADEND_USER="tvheadend"
 TVHEADEND_GROUP="video"
 
 # Path to Tvheadend config.
-TVHEADEND_CONFIG="/etc/tvheadend"
+TVHEADEND_CONFIG="/var/lib/tvheadend"
 
 # Other options you want to pass to Tvheadend.
 TVHEADEND_OPTIONS=""
similarity index 83%
rename from media-tv/tvheadend/tvheadend-4.2.8.ebuild
rename to media-tv/tvheadend/tvheadend-4.2.8-r1.ebuild
index a20bac30f228e9b71792167f1df7db42425c7afb..2c44c55ed1797e35fd8f447995b518c26246ece2 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit linux-info systemd toolchain-funcs user
+inherit linux-info systemd toolchain-funcs
 
 DESCRIPTION="Tvheadend is a TV streaming server and digital video recorder"
 HOMEPAGE="https://tvheadend.org/"
@@ -20,6 +20,7 @@ BDEPEND="
        virtual/pkgconfig"
 
 RDEPEND="
+       acct-user/tvheadend
        virtual/libiconv
        dbus? ( sys-apps/dbus )
        dvbcsa? ( media-libs/libdvbcsa )
@@ -58,8 +59,6 @@ DOCS=( README.md )
 pkg_setup() {
        use inotify &&
                CONFIG_CHECK="~INOTIFY_USER" linux-info_pkg_setup
-
-       enewuser tvheadend -1 -1 /etc/tvheadend video
 }
 
 src_configure() {
@@ -106,10 +105,6 @@ src_install() {
 
        use systemd &&
                systemd_dounit "${FILESDIR}"/tvheadend.service
-
-       dodir /etc/tvheadend
-       fperms 0700 /etc/tvheadend
-       fowners tvheadend:video /etc/tvheadend
 }
 
 pkg_postinst() {
@@ -119,4 +114,15 @@ pkg_postinst() {
        elog "Make sure that you change the default username"
        elog "and password via the Configuration / Access control"
        elog "tab in the web interface."
+
+       . "${EROOT}"/etc/conf.d/tvheadend &>/dev/null
+
+       if [[ ${TVHEADEND_CONFIG} = ${EPREFIX}/etc/tvheadend ]]; then
+               echo
+               ewarn "The HOME directory for the tvheadend user has changed from"
+               ewarn "${EPREFIX}/etc/tvheadend to ${EPREFIX}/var/lib/tvheadend. The daemon will continue"
+               ewarn "to use the old location until you update TVHEADEND_CONFIG in"
+               ewarn "${EPREFIX}/etc/conf.d/tvheadend. Please manually move your existing files"
+               ewarn "before you do so."
+       fi
 }
index 692d4ec897c326f2e59b365385c079cf38ffa664..ddd46284395b1eb418d1e7d08d66936252d7f6e4 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit git-r3 linux-info systemd toolchain-funcs user
+inherit git-r3 linux-info systemd toolchain-funcs
 
 DESCRIPTION="Tvheadend is a TV streaming server and digital video recorder"
 HOMEPAGE="https://tvheadend.org/"
@@ -20,6 +20,7 @@ BDEPEND="
        virtual/pkgconfig"
 
 RDEPEND="
+       acct-user/tvheadend
        virtual/libiconv
        dbus? ( sys-apps/dbus )
        dvbcsa? ( media-libs/libdvbcsa )
@@ -67,8 +68,6 @@ DOCS=( README.md )
 pkg_setup() {
        use inotify &&
                CONFIG_CHECK="~INOTIFY_USER" linux-info_pkg_setup
-
-       enewuser tvheadend -1 -1 /etc/tvheadend video
 }
 
 # We unconditionally enable codecs that do not require additional
@@ -130,10 +129,6 @@ src_install() {
 
        use systemd &&
                systemd_dounit "${FILESDIR}"/tvheadend.service
-
-       dodir /etc/tvheadend
-       fperms 0700 /etc/tvheadend
-       fowners tvheadend:video /etc/tvheadend
 }
 
 pkg_postinst() {
@@ -143,4 +138,15 @@ pkg_postinst() {
        elog "Make sure that you change the default username"
        elog "and password via the Configuration / Access control"
        elog "tab in the web interface."
+
+       . "${EROOT}"/etc/conf.d/tvheadend &>/dev/null
+
+       if [[ ${TVHEADEND_CONFIG} = ${EPREFIX}/etc/tvheadend ]]; then
+               echo
+               ewarn "The HOME directory for the tvheadend user has changed from"
+               ewarn "${EPREFIX}/etc/tvheadend to ${EPREFIX}/var/lib/tvheadend. The daemon will continue"
+               ewarn "to use the old location until you update TVHEADEND_CONFIG in"
+               ewarn "${EPREFIX}/etc/conf.d/tvheadend. Please manually move your existing files"
+               ewarn "before you do so."
+       fi
 }