dev-vcs/git: Adjusted dependencies in EAPI-7 ebuilds
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 6 Nov 2019 08:20:58 +0000 (09:20 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 6 Nov 2019 08:21:08 +0000 (09:21 +0100)
Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com>
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-vcs/git/git-2.24.0.ebuild
dev-vcs/git/git-9999-r1.ebuild
dev-vcs/git/git-9999-r2.ebuild
dev-vcs/git/git-9999-r3.ebuild
dev-vcs/git/git-9999.ebuild

index 9e71c152786ee6375cbe8a62b585911fdfd58922..4bee6fa6ca97f2d6f784c0215111bb3b237062b8 100644 (file)
@@ -54,7 +54,7 @@ SLOT="0"
 IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
-CDEPEND="
+DEPEND="
        gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
@@ -73,7 +73,7 @@ CDEPEND="
        iconv? ( virtual/libiconv )
 "
 
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
        gpg? ( app-crypt/gnupg )
        perl? (
                dev-perl/Error
@@ -106,9 +106,6 @@ RDEPEND="${CDEPEND}
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
 #   .xml/docbook  --(docbook2texi.pl)--> .texi
 #   .texi         --(makeinfo)---------> .info
-DEPEND="${CDEPEND}
-       test? ( app-crypt/gnupg )"
-
 BDEPEND="
        doc? (
                app-text/asciidoc
@@ -117,6 +114,7 @@ BDEPEND="
                sys-apps/texinfo
        )
        nls? ( sys-devel/gettext )
+       test? ( app-crypt/gnupg )
 "
 
 # Live ebuild builds man pages and HTML docs, additionally
index 9e71c152786ee6375cbe8a62b585911fdfd58922..4bee6fa6ca97f2d6f784c0215111bb3b237062b8 100644 (file)
@@ -54,7 +54,7 @@ SLOT="0"
 IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
-CDEPEND="
+DEPEND="
        gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
@@ -73,7 +73,7 @@ CDEPEND="
        iconv? ( virtual/libiconv )
 "
 
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
        gpg? ( app-crypt/gnupg )
        perl? (
                dev-perl/Error
@@ -106,9 +106,6 @@ RDEPEND="${CDEPEND}
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
 #   .xml/docbook  --(docbook2texi.pl)--> .texi
 #   .texi         --(makeinfo)---------> .info
-DEPEND="${CDEPEND}
-       test? ( app-crypt/gnupg )"
-
 BDEPEND="
        doc? (
                app-text/asciidoc
@@ -117,6 +114,7 @@ BDEPEND="
                sys-apps/texinfo
        )
        nls? ( sys-devel/gettext )
+       test? ( app-crypt/gnupg )
 "
 
 # Live ebuild builds man pages and HTML docs, additionally
index 9e71c152786ee6375cbe8a62b585911fdfd58922..4bee6fa6ca97f2d6f784c0215111bb3b237062b8 100644 (file)
@@ -54,7 +54,7 @@ SLOT="0"
 IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
-CDEPEND="
+DEPEND="
        gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
@@ -73,7 +73,7 @@ CDEPEND="
        iconv? ( virtual/libiconv )
 "
 
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
        gpg? ( app-crypt/gnupg )
        perl? (
                dev-perl/Error
@@ -106,9 +106,6 @@ RDEPEND="${CDEPEND}
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
 #   .xml/docbook  --(docbook2texi.pl)--> .texi
 #   .texi         --(makeinfo)---------> .info
-DEPEND="${CDEPEND}
-       test? ( app-crypt/gnupg )"
-
 BDEPEND="
        doc? (
                app-text/asciidoc
@@ -117,6 +114,7 @@ BDEPEND="
                sys-apps/texinfo
        )
        nls? ( sys-devel/gettext )
+       test? ( app-crypt/gnupg )
 "
 
 # Live ebuild builds man pages and HTML docs, additionally
index 9e71c152786ee6375cbe8a62b585911fdfd58922..4bee6fa6ca97f2d6f784c0215111bb3b237062b8 100644 (file)
@@ -54,7 +54,7 @@ SLOT="0"
 IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
-CDEPEND="
+DEPEND="
        gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
@@ -73,7 +73,7 @@ CDEPEND="
        iconv? ( virtual/libiconv )
 "
 
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
        gpg? ( app-crypt/gnupg )
        perl? (
                dev-perl/Error
@@ -106,9 +106,6 @@ RDEPEND="${CDEPEND}
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
 #   .xml/docbook  --(docbook2texi.pl)--> .texi
 #   .texi         --(makeinfo)---------> .info
-DEPEND="${CDEPEND}
-       test? ( app-crypt/gnupg )"
-
 BDEPEND="
        doc? (
                app-text/asciidoc
@@ -117,6 +114,7 @@ BDEPEND="
                sys-apps/texinfo
        )
        nls? ( sys-devel/gettext )
+       test? ( app-crypt/gnupg )
 "
 
 # Live ebuild builds man pages and HTML docs, additionally
index 9e71c152786ee6375cbe8a62b585911fdfd58922..4bee6fa6ca97f2d6f784c0215111bb3b237062b8 100644 (file)
@@ -54,7 +54,7 @@ SLOT="0"
 IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
-CDEPEND="
+DEPEND="
        gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
@@ -73,7 +73,7 @@ CDEPEND="
        iconv? ( virtual/libiconv )
 "
 
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
        gpg? ( app-crypt/gnupg )
        perl? (
                dev-perl/Error
@@ -106,9 +106,6 @@ RDEPEND="${CDEPEND}
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
 #   .xml/docbook  --(docbook2texi.pl)--> .texi
 #   .texi         --(makeinfo)---------> .info
-DEPEND="${CDEPEND}
-       test? ( app-crypt/gnupg )"
-
 BDEPEND="
        doc? (
                app-text/asciidoc
@@ -117,6 +114,7 @@ BDEPEND="
                sys-apps/texinfo
        )
        nls? ( sys-devel/gettext )
+       test? ( app-crypt/gnupg )
 "
 
 # Live ebuild builds man pages and HTML docs, additionally