app-i18n/ibus-libpinyin: version bump, 1.11.92
authorYixun Lan <dlan@gentoo.org>
Fri, 29 May 2020 13:50:01 +0000 (21:50 +0800)
committerYixun Lan <dlan@gentoo.org>
Fri, 29 May 2020 13:54:00 +0000 (21:54 +0800)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Yixun Lan <dlan@gentoo.org>
app-i18n/ibus-libpinyin/Manifest
app-i18n/ibus-libpinyin/ibus-libpinyin-1.11.92.ebuild [new file with mode: 0644]

index 9ae6807a842aaa7d0ad5e0593679847910f77c7c..dd0c070769bfc0a39944196793d814a83c889427 100644 (file)
@@ -1,3 +1,4 @@
 DIST boost.282b1e01f5bc5ae94347474fd8c35cb2f7a7e65d.m4 55907 BLAKE2B 16ac81094457c80b418109104139c1604e38ec58d6065474cc512668601f12896c4d470fe15c9a366a5ec63d50135265df71f28f4202fa283231879fafb0efbc SHA512 382c7f8a94059ae9816783b12c2d27ee6ca69e23ef7085bf2ee5a31109e6ab0c3d0b0042a3dc290b89276b6315d767aedf073dca390fa688a9aae07e837f83c9
 DIST ibus-libpinyin-1.10.0.tar.gz 1693440 BLAKE2B 5e0d9debddfbb81fcb45ac86d1fe8fb1220a50c527222fb3c3431149231f41dcc59ae87da9ae9485e2585f0e3051ac4d1792407ba62d90e5e0323c482d52318f SHA512 c9fdc28562714bddc889805e1d439a7dd425f721a8236b8f8ec4727ce24e5053693b3e5bd9b06ced22ceb66bc7621715f7ee52e00af3b8b113503a5ce6963ca0
 DIST ibus-libpinyin-1.11.1.tar.gz 1728202 BLAKE2B 6e2273c4ff1be76bb8b0e65b915e039c0a181981d20ed94662184e161e8639ad3d548de981d7bbae950ab8b5019bedaed9593e03282e2f9d207f831929d422bc SHA512 48691952a10f4ab545d8e233dc3cd75fc54270c03a687820048152636df26d233ee0fba89e4ec2ccd5a6e410b41e556872e3dd2468d59d44b3440e904b93528b
+DIST ibus-libpinyin-1.11.92.tar.gz 1730065 BLAKE2B 376bec6fa7616364c8ed4dc5b269edabda892ba4759ff03e93b4099c99440925126800ea3bf11eef91ea62c558fa7dbf05f3d68be5e25e701aaaeb37618b90a8 SHA512 b875b2fed6875806971b91e2abc62cdab1f70baef78840915f89466a7bcf3d1dfc70438ba85e7580bba92dec0ade50a2b05955fe6cd148bffd3888fa69f1c851
diff --git a/app-i18n/ibus-libpinyin/ibus-libpinyin-1.11.92.ebuild b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.11.92.ebuild
new file mode 100644 (file)
index 0000000..8a889ff
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 2015-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit autotools gnome2-utils python-single-r1
+
+DESCRIPTION="Intelligent Pinyin and Bopomofo input methods based on LibPinyin for IBus"
+HOMEPAGE="https://github.com/libpinyin/ibus-libpinyin https://sourceforge.net/projects/libpinyin/"
+SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua opencc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="dev-db/sqlite:3
+       virtual/pkgconfig"
+
+DEPEND="${PYTHON_DEPS}
+       >=app-i18n/libpinyin-2.1.0:=
+       dev-db/sqlite:3
+       dev-libs/glib:2
+       virtual/libintl
+       $(python_gen_cond_dep '
+               app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+       ')
+       boost? ( dev-libs/boost:= )
+       lua? ( dev-lang/lua:0 )
+       opencc? ( app-i18n/opencc:= )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --enable-english-input-mode \
+               $(use_enable boost) \
+               $(use_enable lua lua-extension) \
+               $(use_enable opencc)
+}
+
+pkg_postinst() {
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       gnome2_schemas_update
+}