app-antivirus/clamav: cleanup vulnerable wrt bug #636212
authorAaron Bauman <bman@gentoo.org>
Thu, 25 Jan 2018 01:31:36 +0000 (20:31 -0500)
committerAaron Bauman <bman@gentoo.org>
Thu, 25 Jan 2018 01:31:36 +0000 (20:31 -0500)
app-antivirus/clamav/Manifest
app-antivirus/clamav/clamav-0.98.7-r1.ebuild [deleted file]
app-antivirus/clamav/clamav-0.98.7.ebuild [deleted file]
app-antivirus/clamav/clamav-0.99.1.ebuild [deleted file]
app-antivirus/clamav/clamav-0.99.2.ebuild [deleted file]
app-antivirus/clamav/clamav-0.99.ebuild [deleted file]

index 2f052faf2fc82fe5c11fc4b3f6aa6bb733aae286..b82c9c97c9ae4ad46deb2a690af46bbc11c20f2c 100644 (file)
@@ -1,4 +1 @@
-DIST clamav-0.98.7.tar.gz 15118851 BLAKE2B 5fffd1896645b5e77f26819eb16e1d9e9cbb8a71d5627aa31ce009b37172fe5c9fff77d6646940c8065c856cf1a74737ffafc79d4e288b8d1202620fe568d1bc SHA512 acf01961472c13ccb219420cc3fa3c3e6f8a733edef371dbc04ce5867900aa1535e956ec8ad50d31c8f872a0a1d79fcccac944cd86e29ecdfa4af18f7fd5afb9
-DIST clamav-0.99.1.tar.gz 15990867 BLAKE2B 3b5d046c0b4e965ff26bea3b6b416e261ce86c449d092fd1debf52e4df5e5448039f7769f94d5817c9754100d296a0eb37ca5289f3cb5af8e58be9e93ef59a18 SHA512 9beb5c0ebff2aef741bb27811c1f10a7cd5da354ff67272ee8994d87c95e272a5983105af0fe1a734e1fa99f112dc4dddd9d82074a0df6715814817f85a45f4f
 DIST clamav-0.99.2.tar.gz 16067497 BLAKE2B 4155e3125ccc45cc6828033f207b6b8d3514253dfb8156428ad4096c0901d5a8500f9dd253b8f40afdc49a6039b647627868f75d51829ab7bd247ada5f3b8383 SHA512 7744ba8a344b163cf98e9737cddfd25d2120b34ee9c4518380e028c9ec3cd50127b198b0dfa9fde30f5ce9aab0c0e6384712fbc11287e77d16ce052fd7b6ac44
-DIST clamav-0.99.tar.gz 15968038 BLAKE2B d3690f08215b8d870e8fb11b11eea6bb92a2eb4b7edddb037ed2f0e8c823a6c5856a3824716cd04f02ec985188ccd36ae41c5077df09ed1948281012dd28ef8c SHA512 328e66fa412ba61f5e44c839b254c7a84d2ce7821fda6cf29e4ee9532c06e45bdec62f202ca561223e984fff170bfd8280e5cc8e306c09a3017b17e7db3bbf56
diff --git a/app-antivirus/clamav/clamav-0.98.7-r1.ebuild b/app-antivirus/clamav/clamav-0.98.7-r1.ebuild
deleted file mode 100644 (file)
index a8c9f8f..0000000
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic user systemd
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="bzip2 clamdtop iconv ipv6 libressl milter metadata-analysis-api selinux static-libs uclibc"
-
-CDEPEND="bzip2? ( app-arch/bzip2 )
-       clamdtop? ( sys-libs/ncurses:0 )
-       iconv? ( virtual/libiconv )
-       metadata-analysis-api? ( dev-libs/json-c:= )
-       milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
-       dev-libs/libtommath
-       >=sys-libs/zlib-1.2.2
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-devel/libtool"
-# openssl is now *required* see this link as to why
-# http://blog.clamav.net/2014/02/introducing-openssl-as-dependency-to.html
-DEPEND="${CDEPEND}
-       virtual/pkgconfig"
-RDEPEND="${CDEPEND}
-       selinux? ( sec-policy/selinux-clamav )"
-
-DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )
-
-pkg_setup() {
-       enewgroup clamav
-       enewuser clamav -1 -1 /dev/null clamav
-}
-
-src_prepare() {
-       use ppc64 && append-flags -mminimal-toc
-       use uclibc && export ac_cv_type_error_t=yes
-}
-
-src_configure() {
-       econf \
-               --disable-experimental \
-               --disable-fanotify \
-               --enable-id-check \
-               --with-dbdir="${EPREFIX}"/var/lib/clamav \
-               --with-system-tommath \
-               --with-zlib="${EPREFIX}"/usr \
-               $(use_enable bzip2) \
-               $(use_enable clamdtop) \
-               $(use_enable ipv6) \
-               $(use_enable milter) \
-               $(use_enable static-libs static) \
-               $(use_with iconv) \
-               $(use_with metadata-analysis-api libjson /usr)
-}
-
-src_install() {
-       default
-
-       rm -rf "${ED}"/var/lib/clamav
-       newinitd "${FILESDIR}"/clamd.initd-r6 clamd
-       newconfd "${FILESDIR}"/clamd.conf-r1 clamd
-
-       systemd_dotmpfilesd "${FILESDIR}/tmpfiles.d/clamav.conf"
-       systemd_newunit "${FILESDIR}/clamd_at.service" "clamd@.service"
-       systemd_dounit "${FILESDIR}/clamd.service"
-       systemd_dounit "${FILESDIR}/freshclamd.service"
-
-       keepdir /var/lib/clamav
-       fowners clamav:clamav /var/lib/clamav
-       keepdir /var/log/clamav
-       fowners clamav:clamav /var/log/clamav
-
-       dodir /etc/logrotate.d
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/clamav.logrotate clamav
-
-       # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.pid:" \
-               -e "s:.*\(LocalSocket\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.sock:" \
-               -e "s:.*\(User\) .*:\1 clamav:" \
-               -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamd.log:" \
-               -e "s:^\#\(LogTime\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/clamd.conf.sample || die
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/freshclam.pid:" \
-               -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
-               -e "s:^\#\(UpdateLogFile\) .*:\1 ${EPREFIX}/var/log/clamav/freshclam.log:" \
-               -e "s:^\#\(NotifyClamd\).*:\1 ${EPREFIX}/etc/clamd.conf:" \
-               -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/freshclam.conf.sample || die
-
-       if use milter ; then
-               # MilterSocket one to include ' /' because there is a 2nd line for
-               # inet: which we want to leave
-               dodoc "${FILESDIR}"/clamav-milter.README.gentoo
-               sed -i -e "s:^\(Example\):\# \1:" \
-                       -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamav-milter.pid:" \
-                       -e "s+^\#\(ClamdSocket\) .*+\1 unix:${EPREFIX}/var/run/clamav/clamd.sock+" \
-                       -e "s:.*\(User\) .*:\1 clamav:" \
-                       -e "s+^\#\(MilterSocket\) /.*+\1 unix:${EPREFIX}/var/run/clamav/clamav-milter.sock+" \
-                       -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-                       -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamav-milter.log:" \
-                       "${ED}"/etc/clamav-milter.conf.sample || die
-               cat >> "${ED}"/etc/conf.d/clamd <<-EOF
-                       MILTER_NICELEVEL=19
-                       START_MILTER=no
-               EOF
-
-               systemd_newunit "${FILESDIR}/clamav-milter.service-r1" clamav-milter.service
-       fi
-
-       for i in clamd freshclam clamav-milter
-       do
-               [[ -f "${D}"/etc/"${i}".conf.sample ]] && mv "${D}"/etc/"${i}".conf{.sample,}
-       done
-
-       prune_libtool_files --all
-}
-
-pkg_postinst() {
-       if use milter ; then
-               elog "For simple instructions how to setup the clamav-milter read the"
-               elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
-       fi
-       if test -z $(find "${ROOT}"var/lib/clamav -maxdepth 1 -name 'main.c*' -print -quit) ; then
-               ewarn "You must run freshclam manually to populate the virus database files"
-               ewarn "before starting clamav for the first time.\n"
-       fi
-}
diff --git a/app-antivirus/clamav/clamav-0.98.7.ebuild b/app-antivirus/clamav/clamav-0.98.7.ebuild
deleted file mode 100644 (file)
index fa453ad..0000000
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic user systemd
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="bzip2 clamdtop iconv ipv6 milter metadata-analysis-api selinux static-libs uclibc"
-
-CDEPEND="bzip2? ( app-arch/bzip2 )
-       clamdtop? ( sys-libs/ncurses:0= )
-       iconv? ( virtual/libiconv )
-       metadata-analysis-api? ( dev-libs/json-c:= )
-       milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
-       dev-libs/libtommath
-       >=sys-libs/zlib-1.2.2
-       dev-libs/openssl:0
-       sys-devel/libtool"
-# openssl is now *required* see this link as to why
-# http://blog.clamav.net/2014/02/introducing-openssl-as-dependency-to.html
-DEPEND="${CDEPEND}
-       virtual/pkgconfig"
-RDEPEND="${CDEPEND}
-       selinux? ( sec-policy/selinux-clamav )"
-
-DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )
-
-pkg_setup() {
-       enewgroup clamav
-       enewuser clamav -1 -1 /dev/null clamav
-}
-
-src_prepare() {
-       use ppc64 && append-flags -mminimal-toc
-       use uclibc && export ac_cv_type_error_t=yes
-}
-
-src_configure() {
-       econf \
-               --disable-experimental \
-               --disable-fanotify \
-               --enable-id-check \
-               --with-dbdir="${EPREFIX}"/var/lib/clamav \
-               --with-system-tommath \
-               --with-zlib="${EPREFIX}"/usr \
-               $(use_enable bzip2) \
-               $(use_enable clamdtop) \
-               $(use_enable ipv6) \
-               $(use_enable milter) \
-               $(use_enable static-libs static) \
-               $(use_with iconv) \
-               $(use_with metadata-analysis-api libjson /usr)
-}
-
-src_install() {
-       default
-
-       rm -rf "${ED}"/var/lib/clamav
-       newinitd "${FILESDIR}"/clamd.initd-r6 clamd
-       newconfd "${FILESDIR}"/clamd.conf-r1 clamd
-
-       systemd_dotmpfilesd "${FILESDIR}/tmpfiles.d/clamav.conf"
-       systemd_newunit "${FILESDIR}/clamd_at.service" "clamd@.service"
-       systemd_dounit "${FILESDIR}/clamd.service"
-       systemd_dounit "${FILESDIR}/freshclamd.service"
-
-       keepdir /var/lib/clamav
-       fowners clamav:clamav /var/lib/clamav
-       keepdir /var/log/clamav
-       fowners clamav:clamav /var/log/clamav
-
-       dodir /etc/logrotate.d
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/clamav.logrotate clamav
-
-       # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.pid:" \
-               -e "s:.*\(LocalSocket\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.sock:" \
-               -e "s:.*\(User\) .*:\1 clamav:" \
-               -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamd.log:" \
-               -e "s:^\#\(LogTime\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/clamd.conf.sample || die
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/freshclam.pid:" \
-               -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
-               -e "s:^\#\(UpdateLogFile\) .*:\1 ${EPREFIX}/var/log/clamav/freshclam.log:" \
-               -e "s:^\#\(NotifyClamd\).*:\1 ${EPREFIX}/etc/clamd.conf:" \
-               -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/freshclam.conf.sample || die
-
-       if use milter ; then
-               # MilterSocket one to include ' /' because there is a 2nd line for
-               # inet: which we want to leave
-               dodoc "${FILESDIR}"/clamav-milter.README.gentoo
-               sed -i -e "s:^\(Example\):\# \1:" \
-                       -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamav-milter.pid:" \
-                       -e "s+^\#\(ClamdSocket\) .*+\1 unix:${EPREFIX}/var/run/clamav/clamd.sock+" \
-                       -e "s:.*\(User\) .*:\1 clamav:" \
-                       -e "s+^\#\(MilterSocket\) /.*+\1 unix:${EPREFIX}/var/run/clamav/clamav-milter.sock+" \
-                       -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-                       -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamav-milter.log:" \
-                       "${ED}"/etc/clamav-milter.conf.sample || die
-               cat >> "${ED}"/etc/conf.d/clamd <<-EOF
-                       MILTER_NICELEVEL=19
-                       START_MILTER=no
-               EOF
-
-               systemd_newunit "${FILESDIR}/clamav-milter.service-r1" clamav-milter.service
-       fi
-
-       for i in clamd freshclam clamav-milter
-       do
-               [[ -f "${D}"/etc/"${i}".conf.sample ]] && mv "${D}"/etc/"${i}".conf{.sample,}
-       done
-
-       prune_libtool_files --all
-}
-
-pkg_postinst() {
-       if use milter ; then
-               elog "For simple instructions how to setup the clamav-milter read the"
-               elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
-       fi
-       if test -z $(find "${ROOT}"var/lib/clamav -maxdepth 1 -name 'main.c*' -print -quit) ; then
-               ewarn "You must run freshclam manually to populate the virus database files"
-               ewarn "before starting clamav for the first time.\n"
-       fi
-}
diff --git a/app-antivirus/clamav/clamav-0.99.1.ebuild b/app-antivirus/clamav/clamav-0.99.1.ebuild
deleted file mode 100644 (file)
index 1fe996a..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic user systemd
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="bzip2 clamdtop iconv ipv6 libressl milter metadata-analysis-api selinux static-libs uclibc"
-
-CDEPEND="bzip2? ( app-arch/bzip2 )
-       clamdtop? ( sys-libs/ncurses:0 )
-       iconv? ( virtual/libiconv )
-       metadata-analysis-api? ( dev-libs/json-c:= )
-       milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
-       dev-libs/libtommath
-       >=sys-libs/zlib-1.2.2
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-devel/libtool
-       >dev-libs/libpcre-6
-       !!<app-antivirus/clamav-0.99"
-# hard block clamav < 0.99 due to linking problems Bug #567680
-# openssl is now *required* see this link as to why
-# http://blog.clamav.net/2014/02/introducing-openssl-as-dependency-to.html
-DEPEND="${CDEPEND}
-       virtual/pkgconfig"
-RDEPEND="${CDEPEND}
-       selinux? ( sec-policy/selinux-clamav )"
-
-DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )
-
-pkg_setup() {
-       enewgroup clamav
-       enewuser clamav -1 -1 /dev/null clamav
-}
-
-src_prepare() {
-       use ppc64 && append-flags -mminimal-toc
-       use uclibc && export ac_cv_type_error_t=yes
-
-       epatch "${FILESDIR}"/${PN}-0.99-zlib.patch # 604650, fixed in upstream HEAD
-       eautoconf
-}
-
-src_configure() {
-       econf \
-               --disable-experimental \
-               --disable-fanotify \
-               --enable-id-check \
-               --with-dbdir="${EPREFIX}"/var/lib/clamav \
-               --with-system-tommath \
-               --with-zlib="${EPREFIX}"/usr \
-               $(use_enable bzip2) \
-               $(use_enable clamdtop) \
-               $(use_enable ipv6) \
-               $(use_enable milter) \
-               $(use_enable static-libs static) \
-               $(use_with iconv) \
-               $(use_with metadata-analysis-api libjson /usr)
-}
-
-src_install() {
-       default
-
-       rm -rf "${ED}"/var/lib/clamav
-       newinitd "${FILESDIR}"/clamd.initd-r6 clamd
-       newconfd "${FILESDIR}"/clamd.conf-r1 clamd
-
-       systemd_dotmpfilesd "${FILESDIR}/tmpfiles.d/clamav.conf"
-       systemd_newunit "${FILESDIR}/clamd_at.service" "clamd@.service"
-       systemd_dounit "${FILESDIR}/clamd.service"
-       systemd_dounit "${FILESDIR}/freshclamd.service"
-
-       keepdir /var/lib/clamav
-       fowners clamav:clamav /var/lib/clamav
-       keepdir /var/log/clamav
-       fowners clamav:clamav /var/log/clamav
-
-       dodir /etc/logrotate.d
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/clamav.logrotate clamav
-
-       # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.pid:" \
-               -e "s:.*\(LocalSocket\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.sock:" \
-               -e "s:.*\(User\) .*:\1 clamav:" \
-               -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamd.log:" \
-               -e "s:^\#\(LogTime\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/clamd.conf.sample || die
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/freshclam.pid:" \
-               -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
-               -e "s:^\#\(UpdateLogFile\) .*:\1 ${EPREFIX}/var/log/clamav/freshclam.log:" \
-               -e "s:^\#\(NotifyClamd\).*:\1 ${EPREFIX}/etc/clamd.conf:" \
-               -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/freshclam.conf.sample || die
-
-       if use milter ; then
-               # MilterSocket one to include ' /' because there is a 2nd line for
-               # inet: which we want to leave
-               dodoc "${FILESDIR}"/clamav-milter.README.gentoo
-               sed -i -e "s:^\(Example\):\# \1:" \
-                       -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamav-milter.pid:" \
-                       -e "s+^\#\(ClamdSocket\) .*+\1 unix:${EPREFIX}/var/run/clamav/clamd.sock+" \
-                       -e "s:.*\(User\) .*:\1 clamav:" \
-                       -e "s+^\#\(MilterSocket\) /.*+\1 unix:${EPREFIX}/var/run/clamav/clamav-milter.sock+" \
-                       -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-                       -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamav-milter.log:" \
-                       "${ED}"/etc/clamav-milter.conf.sample || die
-               cat >> "${ED}"/etc/conf.d/clamd <<-EOF
-                       MILTER_NICELEVEL=19
-                       START_MILTER=no
-               EOF
-
-               systemd_newunit "${FILESDIR}/clamav-milter.service-r1" clamav-milter.service
-       fi
-
-       for i in clamd freshclam clamav-milter
-       do
-               [[ -f "${D}"/etc/"${i}".conf.sample ]] && mv "${D}"/etc/"${i}".conf{.sample,}
-       done
-
-       prune_libtool_files --all
-}
-
-pkg_postinst() {
-       if use milter ; then
-               elog "For simple instructions how to setup the clamav-milter read the"
-               elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
-       fi
-       if test -z $(find "${ROOT}"var/lib/clamav -maxdepth 1 -name 'main.c*' -print -quit) ; then
-               ewarn "You must run freshclam manually to populate the virus database files"
-               ewarn "before starting clamav for the first time.\n"
-       fi
-}
diff --git a/app-antivirus/clamav/clamav-0.99.2.ebuild b/app-antivirus/clamav/clamav-0.99.2.ebuild
deleted file mode 100644 (file)
index 135d0c2..0000000
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic user systemd
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-# no longer on sf.net from 0.99.2 onwards
-SRC_URI="https://www.clamav.net/downloads/production/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="bzip2 clamdtop iconv ipv6 libressl milter metadata-analysis-api selinux static-libs uclibc"
-
-CDEPEND="bzip2? ( app-arch/bzip2 )
-       clamdtop? ( sys-libs/ncurses:0 )
-       iconv? ( virtual/libiconv )
-       metadata-analysis-api? ( dev-libs/json-c:= )
-       milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
-       dev-libs/libtommath
-       >=sys-libs/zlib-1.2.2
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-devel/libtool
-       >dev-libs/libpcre-6
-       !!<app-antivirus/clamav-0.99"
-# hard block clamav < 0.99 due to linking problems Bug #567680
-# openssl is now *required* see this link as to why
-# http://blog.clamav.net/2014/02/introducing-openssl-as-dependency-to.html
-DEPEND="${CDEPEND}
-       virtual/pkgconfig"
-RDEPEND="${CDEPEND}
-       selinux? ( sec-policy/selinux-clamav )"
-
-DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )
-
-pkg_setup() {
-       enewgroup clamav
-       enewuser clamav -1 -1 /dev/null clamav
-}
-
-src_prepare() {
-       use ppc64 && append-flags -mminimal-toc
-       use uclibc && export ac_cv_type_error_t=yes
-
-       epatch "${FILESDIR}"/${P}-gcc-6.patch #592432
-       epatch "${FILESDIR}"/${PN}-0.99-zlib.patch # 604650, fixed in upstream HEAD
-       eautoconf
-}
-
-src_configure() {
-       econf \
-               --disable-experimental \
-               --disable-fanotify \
-               --enable-id-check \
-               --with-dbdir="${EPREFIX}"/var/lib/clamav \
-               --with-system-tommath \
-               --with-zlib="${EPREFIX}"/usr \
-               $(use_enable bzip2) \
-               $(use_enable clamdtop) \
-               $(use_enable ipv6) \
-               $(use_enable milter) \
-               $(use_enable static-libs static) \
-               $(use_with iconv) \
-               $(use_with metadata-analysis-api libjson /usr)
-}
-
-src_install() {
-       default
-
-       rm -rf "${ED}"/var/lib/clamav
-       newinitd "${FILESDIR}"/clamd.initd-r6 clamd
-       newconfd "${FILESDIR}"/clamd.conf-r1 clamd
-
-       systemd_dotmpfilesd "${FILESDIR}/tmpfiles.d/clamav.conf"
-       systemd_newunit "${FILESDIR}/clamd_at.service" "clamd@.service"
-       systemd_dounit "${FILESDIR}/clamd.service"
-       systemd_dounit "${FILESDIR}/freshclamd.service"
-
-       keepdir /var/lib/clamav
-       fowners clamav:clamav /var/lib/clamav
-       keepdir /var/log/clamav
-       fowners clamav:clamav /var/log/clamav
-
-       dodir /etc/logrotate.d
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/clamav.logrotate clamav
-
-       # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.pid:" \
-               -e "s:.*\(LocalSocket\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.sock:" \
-               -e "s:.*\(User\) .*:\1 clamav:" \
-               -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamd.log:" \
-               -e "s:^\#\(LogTime\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/clamd.conf.sample || die
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/freshclam.pid:" \
-               -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
-               -e "s:^\#\(UpdateLogFile\) .*:\1 ${EPREFIX}/var/log/clamav/freshclam.log:" \
-               -e "s:^\#\(NotifyClamd\).*:\1 ${EPREFIX}/etc/clamd.conf:" \
-               -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/freshclam.conf.sample || die
-
-       if use milter ; then
-               # MilterSocket one to include ' /' because there is a 2nd line for
-               # inet: which we want to leave
-               dodoc "${FILESDIR}"/clamav-milter.README.gentoo
-               sed -i -e "s:^\(Example\):\# \1:" \
-                       -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamav-milter.pid:" \
-                       -e "s+^\#\(ClamdSocket\) .*+\1 unix:${EPREFIX}/var/run/clamav/clamd.sock+" \
-                       -e "s:.*\(User\) .*:\1 clamav:" \
-                       -e "s+^\#\(MilterSocket\) /.*+\1 unix:${EPREFIX}/var/run/clamav/clamav-milter.sock+" \
-                       -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-                       -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamav-milter.log:" \
-                       "${ED}"/etc/clamav-milter.conf.sample || die
-               cat >> "${ED}"/etc/conf.d/clamd <<-EOF
-                       MILTER_NICELEVEL=19
-                       START_MILTER=no
-               EOF
-
-               systemd_newunit "${FILESDIR}/clamav-milter.service-r1" clamav-milter.service
-       fi
-
-       for i in clamd freshclam clamav-milter
-       do
-               [[ -f "${D}"/etc/"${i}".conf.sample ]] && mv "${D}"/etc/"${i}".conf{.sample,}
-       done
-
-       prune_libtool_files --all
-}
-
-pkg_postinst() {
-       if use milter ; then
-               elog "For simple instructions how to setup the clamav-milter read the"
-               elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
-       fi
-       if test -z $(find "${ROOT}"var/lib/clamav -maxdepth 1 -name 'main.c*' -print -quit) ; then
-               ewarn "You must run freshclam manually to populate the virus database files"
-               ewarn "before starting clamav for the first time.\n"
-       fi
-}
diff --git a/app-antivirus/clamav/clamav-0.99.ebuild b/app-antivirus/clamav/clamav-0.99.ebuild
deleted file mode 100644 (file)
index 3c4f211..0000000
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic user systemd
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="bzip2 clamdtop iconv ipv6 libressl milter metadata-analysis-api selinux static-libs uclibc"
-
-CDEPEND="bzip2? ( app-arch/bzip2 )
-       clamdtop? ( sys-libs/ncurses:0 )
-       iconv? ( virtual/libiconv )
-       metadata-analysis-api? ( dev-libs/json-c:= )
-       milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
-       dev-libs/libtommath
-       >=sys-libs/zlib-1.2.2
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-devel/libtool
-       >dev-libs/libpcre-6
-       !!<app-antivirus/clamav-0.99"
-# hard block clamav < 0.99 due to linking problems Bug #567680
-# openssl is now *required* see this link as to why
-# http://blog.clamav.net/2014/02/introducing-openssl-as-dependency-to.html
-DEPEND="${CDEPEND}
-       virtual/pkgconfig"
-RDEPEND="${CDEPEND}
-       selinux? ( sec-policy/selinux-clamav )"
-
-DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )
-
-pkg_setup() {
-       enewgroup clamav
-       enewuser clamav -1 -1 /dev/null clamav
-}
-
-src_prepare() {
-       use ppc64 && append-flags -mminimal-toc
-       use uclibc && export ac_cv_type_error_t=yes
-
-       epatch "${FILESDIR}"/${P}-zlib.patch # 604650, fixed in upstream HEAD
-       eautoconf
-}
-
-src_configure() {
-       econf \
-               --disable-experimental \
-               --disable-fanotify \
-               --disable-zlib-vcheck \
-               --enable-id-check \
-               --with-dbdir="${EPREFIX}"/var/lib/clamav \
-               --with-system-tommath \
-               --with-zlib="${EPREFIX}"/usr \
-               $(use_enable bzip2) \
-               $(use_enable clamdtop) \
-               $(use_enable ipv6) \
-               $(use_enable milter) \
-               $(use_enable static-libs static) \
-               $(use_with iconv) \
-               $(use_with metadata-analysis-api libjson /usr)
-}
-
-src_install() {
-       default
-
-       rm -rf "${ED}"/var/lib/clamav
-       newinitd "${FILESDIR}"/clamd.initd-r6 clamd
-       newconfd "${FILESDIR}"/clamd.conf-r1 clamd
-
-       systemd_dotmpfilesd "${FILESDIR}/tmpfiles.d/clamav.conf"
-       systemd_newunit "${FILESDIR}/clamd_at.service" "clamd@.service"
-       systemd_dounit "${FILESDIR}/clamd.service"
-       systemd_dounit "${FILESDIR}/freshclamd.service"
-
-       keepdir /var/lib/clamav
-       fowners clamav:clamav /var/lib/clamav
-       keepdir /var/log/clamav
-       fowners clamav:clamav /var/log/clamav
-
-       dodir /etc/logrotate.d
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/clamav.logrotate clamav
-
-       # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.pid:" \
-               -e "s:.*\(LocalSocket\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.sock:" \
-               -e "s:.*\(User\) .*:\1 clamav:" \
-               -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamd.log:" \
-               -e "s:^\#\(LogTime\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/clamd.conf.sample || die
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/freshclam.pid:" \
-               -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
-               -e "s:^\#\(UpdateLogFile\) .*:\1 ${EPREFIX}/var/log/clamav/freshclam.log:" \
-               -e "s:^\#\(NotifyClamd\).*:\1 ${EPREFIX}/etc/clamd.conf:" \
-               -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/freshclam.conf.sample || die
-
-       if use milter ; then
-               # MilterSocket one to include ' /' because there is a 2nd line for
-               # inet: which we want to leave
-               dodoc "${FILESDIR}"/clamav-milter.README.gentoo
-               sed -i -e "s:^\(Example\):\# \1:" \
-                       -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamav-milter.pid:" \
-                       -e "s+^\#\(ClamdSocket\) .*+\1 unix:${EPREFIX}/var/run/clamav/clamd.sock+" \
-                       -e "s:.*\(User\) .*:\1 clamav:" \
-                       -e "s+^\#\(MilterSocket\) /.*+\1 unix:${EPREFIX}/var/run/clamav/clamav-milter.sock+" \
-                       -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-                       -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamav-milter.log:" \
-                       "${ED}"/etc/clamav-milter.conf.sample || die
-               cat >> "${ED}"/etc/conf.d/clamd <<-EOF
-                       MILTER_NICELEVEL=19
-                       START_MILTER=no
-               EOF
-
-               systemd_newunit "${FILESDIR}/clamav-milter.service-r1" clamav-milter.service
-       fi
-
-       for i in clamd freshclam clamav-milter
-       do
-               [[ -f "${D}"/etc/"${i}".conf.sample ]] && mv "${D}"/etc/"${i}".conf{.sample,}
-       done
-
-       prune_libtool_files --all
-}
-
-pkg_postinst() {
-       if use milter ; then
-               elog "For simple instructions how to setup the clamav-milter read the"
-               elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
-       fi
-       if test -z $(find "${ROOT}"var/lib/clamav -maxdepth 1 -name 'main.c*' -print -quit) ; then
-               ewarn "You must run freshclam manually to populate the virus database files"
-               ewarn "before starting clamav for the first time.\n"
-       fi
-}