sys-libs/libxcrypt: Fix tests in 4.4.10-r1
authorPatrick McLean <chutzpah@gentoo.org>
Thu, 7 Nov 2019 06:03:03 +0000 (22:03 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 7 Nov 2019 06:03:32 +0000 (22:03 -0800)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
sys-libs/libxcrypt/libxcrypt-4.4.10-r1.ebuild

index 75fc58ebd03184eb6062d0c6b2848aca35f7a99b..8e27bd3934b48292b4043dda529858205e080086 100644 (file)
@@ -20,7 +20,10 @@ DEPEND="system? (
        )"
 RDEPEND="${DEPEND}"
 BDEPEND="sys-apps/findutils
-       test? ( ${PYTHON_DEPS} )"
+       test? (
+               ${PYTHON_DEPS}
+               $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]')
+       )"
 
 # Gentoo CI complained about not having this
 RESTRICT="!test? ( test )"
@@ -84,7 +87,7 @@ src_compile() {
 }
 
 multilib_src_test() {
-       multibuild_foreach_variant run_in_build_dir emake check
+       emake check
 }
 
 src_test() {