dev-go/go-protobuf: remove old snapshot
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 23:21:13 +0000 (18:21 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 23:29:19 +0000 (18:29 -0500)
dev-go/go-protobuf/Manifest
dev-go/go-protobuf/go-protobuf-0_pre20150727.ebuild [deleted file]

index 79b0ac253f565c7cb3989b50c966b32368e22f45..fe2000ee0b00585ceec328c1c4e9dd33b738f2e9 100644 (file)
@@ -1,2 +1 @@
-DIST go-protobuf-0_pre20150727.tar.gz 151982 SHA256 160ad98eb1477492476ba566d218262fe6d326410d5a030c6a00433eaf7f9006 SHA512 04802b8d74ccaa17f9fc030badd0e74b6e47233ca5f1faab7c49f25bef2f06efd97aa4bf3f4783a7815958354744ddb9fee96d183aebbb03864069b0cc569564 WHIRLPOOL f49157a4a1a48c67b72ed38121ba28aec3f9b3405a3388097caba36643715c14b6915f9bcbd04f974fa98e9f2c4c4a4e313480ef307701c0ace734e9c214c010
 DIST go-protobuf-0_pre20150809.tar.gz 151982 SHA256 160ad98eb1477492476ba566d218262fe6d326410d5a030c6a00433eaf7f9006 SHA512 04802b8d74ccaa17f9fc030badd0e74b6e47233ca5f1faab7c49f25bef2f06efd97aa4bf3f4783a7815958354744ddb9fee96d183aebbb03864069b0cc569564 WHIRLPOOL f49157a4a1a48c67b72ed38121ba28aec3f9b3405a3388097caba36643715c14b6915f9bcbd04f974fa98e9f2c4c4a4e313480ef307701c0ace734e9c214c010
diff --git a/dev-go/go-protobuf/go-protobuf-0_pre20150727.ebuild b/dev-go/go-protobuf/go-protobuf-0_pre20150727.ebuild
deleted file mode 100644 (file)
index e979d5c..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EGO_SRC=github.com/golang/protobuf
-EGO_PN=${EGO_SRC}/...
-
-if [[ ${PV} = *9999* ]]; then
-       inherit golang-vcs
-else
-       KEYWORDS="~amd64"
-       EGIT_COMMIT="68c687dc49948540b356a6b47931c9be4fcd0245"
-       SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-fi
-inherit golang-build
-
-DESCRIPTION="Go support for Google's protocol buffers"
-HOMEPAGE="https://${EGO_SRC}"
-LICENSE="BSD"
-SLOT="0/${PV}"
-IUSE=""
-DEPEND=""
-RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
-       local f
-
-       for f in ${A}
-       do
-               case "${f}" in
-                       *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
-                               local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
-                               debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
-                               # XXX: check whether the directory structure inside is
-                               # fine? i.e. if the tarball has actually a parent dir.
-                               mkdir -p "${destdir}" || die
-                               tar -C "${destdir}" -x --strip-components 1 \
-                                       -f "${DISTDIR}/${f}" || die
-                               ;;
-                       *)
-                               debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
-                               # fall back to the default method
-                               unpack "${f}"
-                               ;;
-               esac
-       done
-}
-fi
-
-src_install() {
-       rm -rf src/${EGO_SRC}/.git* || die
-       golang-build_src_install
-       dobin bin/*
-}