app-admin/puppet-agent: 6.9.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 20 Sep 2019 20:57:05 +0000 (15:57 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 20 Sep 2019 21:07:25 +0000 (16:07 -0500)
Package-Manager: Portage-2.3.69, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-6.9.0.ebuild [new file with mode: 0644]

index 99a6098867e6092b9f96f1a9057c29da71991a7a..e6c6f0a2fdca0653e2f353e5b59f7410e610777e 100644 (file)
@@ -4,3 +4,5 @@ DIST puppet-agent_6.7.2-1stretch_amd64.deb 19184682 BLAKE2B 6078c1b21f0e737881d9
 DIST puppet-agent_6.7.2-1stretch_i386.deb 19452604 BLAKE2B 1915e7b7085db6cb87980a98a7cb85881331719e2af98b07f8461514a0296b3cf5181eb88f78893055a0fa09fc2ffce0e81e866db27abcecf9d8f745e329311c SHA512 8d89735601c9764e207eef77f5d42e836ee9d7c0c0f2856e0f293919cce52e7a42fc28fca42bd0e0bed760063aae527007ef7ce25503ce05fcfd495a44243ee3
 DIST puppet-agent_6.8.0-1stretch_amd64.deb 19184708 BLAKE2B ac961857784eaaa55604285cf305dac437007628ea5baa3c3ae9a8a345fcb8cf2b20820bd80cc2c96afb77cb03c4d2779b17b1183c9bc9461b56860d2179f448 SHA512 707146f71b21df4b89244df7b786f481136cfe7b0cabf20aa0d4784aca547ba85c75d13309b77c853b9e034b8271f350b30bc5358010d90b7573e3fdb63c31b6
 DIST puppet-agent_6.8.0-1stretch_i386.deb 19478404 BLAKE2B 0b9d76bb3d745ca42e489e16a133d684aa0e485941d59c6773c447f5fc79be7a964f0a2ff9e4c334a47b7d2ffc0264bd49e4f7806cbc2e72e037da1c9e385d51 SHA512 f8bc962b32abbaf070b81245b7488b4fc131d5a9e3ec94ac97038f5e9c942c70a493e61e13190fe2837eb898518724bb5f360b37531003dab37606436d66219b
+DIST puppet-agent_6.9.0-1stretch_amd64.deb 19846122 BLAKE2B 7f9133d1f5cb85f45c96490c230ee0cfda707db390a3a39be218fcd730e2298099e6d70c4f44bb5c6af46736c2c8aa7906a16375088c0119045dc77b53343b91 SHA512 f96cb1a6108a21192493b7b9958243e537ab41ce3ab6a7dde4d12bcd5da25ec6a5b29632acb87c4e156256578e8348c6fdfe26043539292f98203cce69b04fff
+DIST puppet-agent_6.9.0-1stretch_i386.deb 20170516 BLAKE2B 391a61a847bc05f9f03885f2e2140ea42b4eeca247f3223f17a82d3ede2e1bbc88226f9794777f4b20e81943d94b11612f8d4ffd9f74c2f494bdc242fb05e1a1 SHA512 595dbe1591a8ee9d703a3efdf103a3095966b22cafd0fd63fb2a7b9274ea858b55d0b915ecc32e93c49bcbeba453654fc9126efe3855924fb5c5b6732e0af83d
diff --git a/app-admin/puppet-agent/puppet-agent-6.9.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.9.0.ebuild
new file mode 100644 (file)
index 0000000..a72df73
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+       amd64? ( ${SRC_BASE}_amd64.deb )
+       x86?   ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+       !app-admin/puppet
+       !dev-ruby/hiera
+       !dev-ruby/facter
+       !app-emulation/virt-what"
+
+DEPEND="
+       ${CDEPEND}"
+RDEPEND="${CDEPEND}
+       app-portage/eix
+       sys-apps/dmidecode
+       sys-libs/glibc
+       sys-libs/readline:0/7
+       sys-libs/ncurses:0[tinfo]
+       selinux? (
+               sys-libs/libselinux[ruby]
+               sec-policy/selinux-puppet
+       )
+       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+       enewgroup puppet
+       enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+       # conf.d
+       doconfd etc/default/puppet
+       doconfd etc/default/pxp-agent
+       # logrotate.d
+       insinto /etc/logrotate.d
+       doins etc/logrotate.d/pxp-agent
+       # puppet itself
+       insinto /etc/puppetlabs
+       doins -r etc/puppetlabs/*
+       # logdir for systemd
+       dodir var/log/puppetlabs/puppet/
+       fperms 0750 var/log/puppetlabs/puppet/
+       # the rest
+       insinto /opt
+       dodir opt/puppetlabs/puppet/cache
+       doins -r opt/*
+       fperms 0750 /opt/puppetlabs/puppet/cache
+       # init
+       newinitd "${FILESDIR}/puppet.initd" puppet
+       systemd_dounit lib/systemd/system/puppet.service
+       systemd_dounit lib/systemd/system/pxp-agent.service
+       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+       # symlinks
+       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+       dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+       dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}