dev-python/QtPy: Drop USE webkit
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 26 Feb 2020 20:33:32 +0000 (21:33 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 26 Feb 2020 21:56:42 +0000 (22:56 +0100)
Bug: https://bugs.gentoo.org/709866
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/QtPy/QtPy-1.9.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/QtPy/QtPy-1.9.0-r1.ebuild b/dev-python/QtPy/QtPy-1.9.0-r1.ebuild
new file mode 100644 (file)
index 0000000..c9e168b
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstraction layer for PyQt5/PySide"
+HOMEPAGE="https://github.com/spyder-ide/qtpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="designer gui opengl svg testlib webengine"
+
+RDEPEND="
+       dev-python/PyQt5[${PYTHON_USEDEP},designer?,opengl?,svg?]
+       gui? ( dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets] )
+       testlib? ( dev-python/PyQt5[${PYTHON_USEDEP},testlib] )
+       webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+       default
+
+       sed -i -e "s/from PyQt4.Qt import/raise ImportError #/" qtpy/__init__.py || die
+       sed -i -e "s/from PySide import/raise ImportError #/" qtpy/__init__.py || die
+       sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
+}