dev-python/automat: Drop 0.5.0, 0.6.0, 0.7.0
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 22 Feb 2020 15:49:21 +0000 (16:49 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 22 Feb 2020 20:22:15 +0000 (21:22 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/automat/Manifest
dev-python/automat/automat-0.5.0.ebuild [deleted file]
dev-python/automat/automat-0.6.0.ebuild [deleted file]
dev-python/automat/automat-0.7.0.ebuild [deleted file]

index a278fa8c8a96e9c4f8d4e5d52ee2575dbb5762ed..1cb5e1e7e877351ade72fd25230d13bc4d3ef879 100644 (file)
@@ -1,4 +1 @@
-DIST Automat-0.5.0.tar.gz 32599 BLAKE2B 951da8840c2334fe3cd86804b39beedaad0d344d66742e8bb72e2d2ace2029b037acac8ffccc5643fd37f81020a567374a25ed42f7bc386770a30956464f52eb SHA512 7b4fc64e1b3cc514e3513c4be7387309a9e0c6d59ef091131404642b517a324b4a0eb677bee99da038664bd6713f2d2078c621f056e98b35966caf324741eeeb
-DIST Automat-0.6.0.tar.gz 31767 BLAKE2B 28baa9d6cc7497f9c0a4b7f4050b197d3dff871b91f5f3e29bdc47ace443af8de0fbeacf1657dc6565b3ab824365362a42204d6d89a8dfc82eaa6cd92d4e2308 SHA512 94f2fa06b0e0e1c0538bcf4bd9046ea40600a018bdd1da2d5bed479877807ad56e448c4f1d7ec87341f80013ae6c35b01201cbe3c4ecae1105419038ed43024d
-DIST Automat-0.7.0.tar.gz 61461 BLAKE2B dd09ce090c7333ee17b701bde2c78e01dacf40cefee847061a2019bb27f0982091e7628737211421ada351937caf9c6734cb445ee6462ce84b381030b013bd05 SHA512 a6f307d312a3ceb721071b5212297c73d2306894b5fafd39265578041a2859bd6f041ac43a654bdda4175a70a4e90e0db1ee35cd43fa620cd5c594b5d1988a74
 DIST Automat-0.8.0.tar.gz 59687 BLAKE2B 56e4ec76564d321ca9a709c484077a4003eea2842160e226728aaaa4ec6ebc2486482f79cd919bef7bbec8baeee7a34ca2a11d48665bb36c79c5a45a3c97e992 SHA512 2dbd4e784f65b02a8c93fc5f15236df3649d667a9792f6cac929dbac5d971495bdab4825df0fcd6817b9a9f79b7a5d8cfbdf8e4d18605f0761546b31b3091ad7
diff --git a/dev-python/automat/automat-0.5.0.ebuild b/dev-python/automat/automat-0.5.0.ebuild
deleted file mode 100644 (file)
index da69ebd..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6)
-
-inherit distutils-r1
-
-MYPN="Automat"
-MYP="${MYPN}-${PV}"
-
-DESCRIPTION="Self-service finite-state machines for the programmer on the go"
-HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/attrs[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/m2r[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-S=${WORKDIR}/${MYP}
-
-python_test() {
-       PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-src_install() {
-       if use examples; then
-               docinto examples
-               dodoc docs/examples/*.py
-       fi
-       distutils-r1_src_install
-}
-
-pkg_postinst() {
-       einfo "For additional visualization functionality install these optional dependencies"
-       einfo "    >=dev-python/twisted-16.1.1"
-       einfo "    media-gfx/graphviz[python]"
-}
diff --git a/dev-python/automat/automat-0.6.0.ebuild b/dev-python/automat/automat-0.6.0.ebuild
deleted file mode 100644 (file)
index 9e702eb..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6)
-
-inherit distutils-r1
-
-MYPN="Automat"
-MYP="${MYPN}-${PV}"
-
-DESCRIPTION="Self-service finite-state machines for the programmer on the go"
-HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/attrs[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/m2r[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-S=${WORKDIR}/${MYP}
-
-python_test() {
-       PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-src_install() {
-       if use examples; then
-               docinto examples
-               dodoc docs/examples/*.py
-       fi
-       distutils-r1_src_install
-}
-
-pkg_postinst() {
-       einfo "For additional visualization functionality install these optional dependencies"
-       einfo "    >=dev-python/twisted-16.1.1"
-       einfo "    media-gfx/graphviz[python]"
-}
diff --git a/dev-python/automat/automat-0.7.0.ebuild b/dev-python/automat/automat-0.7.0.ebuild
deleted file mode 100644 (file)
index 7fda0cb..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7})
-
-inherit distutils-r1
-
-MYPN="Automat"
-MYP="${MYPN}-${PV}"
-
-DESCRIPTION="Self-service finite-state machines for the programmer on the go"
-HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/attrs[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/m2r[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-S=${WORKDIR}/${MYP}
-
-python_prepare_all() {
-       if use test ; then
-               # Remove since this is upstream benchmarking tests
-               rm -r benchmark || die "FAILED to remove benchmark tests"
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-src_install() {
-       if use examples; then
-               docinto examples
-               dodoc docs/examples/*.py
-       fi
-       distutils-r1_src_install
-}
-
-pkg_postinst() {
-       einfo "For additional visualization functionality install these optional dependencies"
-       einfo "    >=dev-python/twisted-16.1.1"
-       einfo "    media-gfx/graphviz[python]"
-}