www-client/chromium: beta channel bump to 83.0.4103.44
authorStephan Hartmann <stha09@googlemail.com>
Fri, 8 May 2020 15:08:33 +0000 (17:08 +0200)
committerMike Gilbert <floppym@gentoo.org>
Fri, 8 May 2020 16:23:00 +0000 (12:23 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/15715

www-client/chromium/Manifest
www-client/chromium/chromium-83.0.4103.44.ebuild [moved from www-client/chromium/chromium-83.0.4103.34.ebuild with 99% similarity]
www-client/chromium/files/chromium-82-gcc-constexpr.patch [deleted file]

index ccd1a769bb5959ece216766dff5f9a4a539d0378..2b527f354c79e4701af09b8ddc28b70a80b77231 100644 (file)
@@ -1,3 +1,3 @@
 DIST chromium-81.0.4044.138.tar.xz 785960928 BLAKE2B fb8ea6aae55450e820f91fc8be7948ac0155beb0fc6a05988506a78b3306ffc52e69b10d3c91e4a29fe2171f339d5331e9524d3e4cd08de57e090ce16412a673 SHA512 9f686b27b2f8ea5c15f50b0ddcd24745aec41e28af8c38618e18771401bd5cfb26939b9ac49973ea804cda458a939c1a6ad59cb24fb1937b7687c3d908183437
-DIST chromium-83.0.4103.34.tar.xz 802525184 BLAKE2B d5e47c96642fb9344fe43a582d035f507b714565c01b6bacbf1cd4fdb3537db28ae0e54a47bbd7f47ad4d00960ee9e40d9a10522262cba4063f95501225fce75 SHA512 467006d3b3093b078569c0ead9203e66cfd83ad14ed95a07b5f83e49451a0e9f4506b3ce35c97106b4540b55484d6cd33afbacf92385ace261e78d5c1cc0188e
+DIST chromium-83.0.4103.44.tar.xz 802603488 BLAKE2B 3f36c311519c85604d6b627b8ae56e60fc617f0290ca34ed05473482782b0db88f4171077531d3ec3efa4c633200a883b4e80fafb1bd37828476f1863d1cdcd5 SHA512 78664cfc37c898410d08b3cf71faf63e6980711b9ae69b020b93b2fab5bcd9c191c0fd91eed21b5ccaabc032ff530f3ae5b9845f7f23c72c3e492ef356da9c6f
 DIST setuptools-44.1.0.zip 858569 BLAKE2B f59f154e121502a731e51294ccd293d60ffccadacf51e23b53bf7ceba38858948b86783238061136c827ac3373ea7ea8e6253d4bb53f3f1dd69284568ec65a68 SHA512 4dfb0f42d334b835758e865a26ecd1e725711fa2b9c38ddc273b8b3849fba04527bc97436d11ba1e98f1a42922aa0f0b9032e32998273c705fac6e10735eacbf
similarity index 99%
rename from www-client/chromium/chromium-83.0.4103.34.ebuild
rename to www-client/chromium/chromium-83.0.4103.44.ebuild
index fd3bf1f334adf461541711d0f2db22ff5d79286a..eea3d4b18eadfb4e086ffbc74016d93e7a339820 100644 (file)
@@ -170,7 +170,6 @@ PATCHES=(
        "${FILESDIR}/chromium-78-protobuf-export.patch"
        "${FILESDIR}/chromium-79-gcc-alignas.patch"
        "${FILESDIR}/chromium-80-gcc-quiche.patch"
-       "${FILESDIR}/chromium-82-gcc-constexpr.patch"
        "${FILESDIR}/chromium-82-gcc-noexcept.patch"
        "${FILESDIR}/chromium-82-gcc-incomplete-type.patch"
        "${FILESDIR}/chromium-82-gcc-template.patch"
diff --git a/www-client/chromium/files/chromium-82-gcc-constexpr.patch b/www-client/chromium/files/chromium-82-gcc-constexpr.patch
deleted file mode 100644 (file)
index 30a8339..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From 5812cd9bc2c15a034db24e0d2a43cc923d8a66cc Mon Sep 17 00:00:00 2001
-From: Jose Dapena Paz <jdapena@igalia.com>
-Date: Thu, 20 Feb 2020 13:00:16 +0100
-Subject: [PATCH] GCC: DOMRect constexpr equal operator depends on non constexpr operators
-
-Make accessors of DOMRectReadOnly constexpr so the equal operator can be
-also constexpr.
-
-../../third_party/blink/renderer/core/geometry/dom_rect.h: In function ‘constexpr bool blink::operator==(const blink::DOMRect&, const blink::DOMRect&)’:
-../../third_party/blink/renderer/core/geometry/dom_rect.h:38:15: error: call to non-‘constexpr’ function ‘double blink::DOMRectReadOnly::x() const’
-
-Bug: 819294
-Change-Id: Ic1fed89c5480ce4eedaaf7add2779d000b77cc48
----
-
-diff --git a/third_party/blink/renderer/core/geometry/dom_rect_read_only.h b/third_party/blink/renderer/core/geometry/dom_rect_read_only.h
-index 0c3f84c..71f193e 100644
---- a/third_party/blink/renderer/core/geometry/dom_rect_read_only.h
-+++ b/third_party/blink/renderer/core/geometry/dom_rect_read_only.h
-@@ -31,10 +31,10 @@ class CORE_EXPORT DOMRectReadOnly : public ScriptWrappable {
-   DOMRectReadOnly(double x, double y, double width, double height);
--  double x() const { return x_; }
--  double y() const { return y_; }
--  double width() const { return width_; }
--  double height() const { return height_; }
-+  constexpr double x() const { return x_; }
-+  constexpr double y() const { return y_; }
-+  constexpr double width() const { return width_; }
-+  constexpr double height() const { return height_; }
-   double top() const { return geometry_util::NanSafeMin(y_, y_ + height_); }
-   double right() const { return geometry_util::NanSafeMax(x_, x_ + width_); }