app-shells/hstr: Update patch to first detect ncursesw
authorJustin Lecher <jlec@gentoo.org>
Fri, 28 Aug 2015 13:09:12 +0000 (15:09 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 28 Aug 2015 13:09:16 +0000 (15:09 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
app-shells/hstr/files/hstr-1.17-tinfo.patch

index 5c9ea9bab4c6b3112d927a5e8b4f57a132ebaada..0ffbd0cff257ff854926f7f254a72a5a5909c3a6 100644 (file)
@@ -1,25 +1,14 @@
- configure.ac    | 22 ++++++++++++----------
- src/Makefile.am |  2 ++
- 2 files changed, 14 insertions(+), 10 deletions(-)
-
 diff --git a/configure.ac b/configure.ac
-index 9cf6a53..7367a32 100644
+index 9cf6a53..cbc649d 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -18,17 +18,19 @@ AC_PROG_CC
+@@ -18,17 +18,21 @@ AC_PROG_CC
  
  # Platform specific ncurses check.
  AC_CANONICAL_HOST
 -AS_CASE([$host_os],
 -  [darwin*],
-+PKG_CHECK_MODULES([NCURSES], [ncurses], [], [
-+  AS_CASE([$host_os],
-+    [darwin*],
-+      [
-+        AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
-+        AC_CHECK_HEADER(curses.h)
-+      ],
-     [
+-    [
 -      AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
 -      AC_CHECK_HEADER(curses.h)
 -    ],
@@ -28,10 +17,20 @@ index 9cf6a53..7367a32 100644
 -    AC_CHECK_HEADER(ncursesw/curses.h)
 -  ]
 -)
-+      AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
-+      AC_CHECK_HEADER(ncursesw/curses.h)
-+    ]
-+  )
++PKG_CHECK_MODULES([NCURSES], [ncursesw], [], [
++  PKG_CHECK_MODULES([NCURSES], [ncurses], [], [
++    AS_CASE([$host_os],
++      [darwin*],
++        [
++          AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
++          AC_CHECK_HEADER(curses.h)
++        ],
++      [
++        AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
++        AC_CHECK_HEADER(ncursesw/curses.h)
++      ]
++    )
++  ])
 +])
  
  # Checks for libraries.