app-editors/emacs: Output warning message for USE="-gtk gtk2".
authorUlrich Müller <ulm@gentoo.org>
Fri, 24 Aug 2018 05:24:13 +0000 (07:24 +0200)
committerUlrich Müller <ulm@gentoo.org>
Fri, 24 Aug 2018 05:24:13 +0000 (07:24 +0200)
Package-Manager: Portage-2.3.47, Repoman-2.3.10

app-editors/emacs/emacs-24.5-r6.ebuild
app-editors/emacs/emacs-25.3-r5.ebuild
app-editors/emacs/emacs-26.1-r2.ebuild

index 3babea9437c957663e8daab50e0ed42fa46b0cf7..3f797276d1963d7bddc8016cee5093e39a830d0a 100644 (file)
@@ -194,6 +194,8 @@ src_configure() {
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
+               ! use gtk && use gtk2 && ewarn \
+                       "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"
index ad5be25089c50199b13d702911b6cb38d55ba7e9..4860c32fe92a66ea7f45825b7c195bba2fdccb2b 100644 (file)
@@ -201,6 +201,8 @@ src_configure() {
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
+               ! use gtk && use gtk2 && ewarn \
+                       "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"
index 123cb6e277ccb93e1132c833df964c379cc5b0ba..d2dd29112e54fe04ed659597a9a44ac1fb6bcd3e 100644 (file)
@@ -214,8 +214,12 @@ src_configure() {
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
-               ! use gtk && use xwidgets && ewarn \
-                       "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               if ! use gtk; then
+                       use gtk2 && ewarn \
+                               "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
+                       use xwidgets && ewarn \
+                               "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               fi
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"