virtual/python-futures: add pypy3 to PYTHON_COMPAT
authorVirgil Dupras <vdupras@gentoo.org>
Sun, 27 Jan 2019 18:59:50 +0000 (13:59 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Sun, 27 Jan 2019 19:00:08 +0000 (14:00 -0500)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

virtual/python-futures/python-futures-1.ebuild [new file with mode: 0644]

diff --git a/virtual/python-futures/python-futures-1.ebuild b/virtual/python-futures/python-futures-1.ebuild
new file mode 100644 (file)
index 0000000..5519243
--- /dev/null
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python concurrent.futures module"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' python2_7 pypy)"