app-emulation/pcem: fix compilation with gcc >= 10.x
authorConrad Kostecki <conikost@gentoo.org>
Sat, 21 Mar 2020 17:00:07 +0000 (18:00 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Sat, 21 Mar 2020 17:01:37 +0000 (18:01 +0100)
Since the source fix is not trivial, adding -fcommon for now.

Closes: https://bugs.gentoo.org/713772
Package-Manager: Portage-2.3.94, Repoman-2.3.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
app-emulation/pcem/pcem-15-r1.ebuild

index db947638e010c0def4e1610799d954db53b7dad6..fad135956903c7b27be4b8df4415995a86416994 100644 (file)
@@ -41,6 +41,10 @@ src_prepare() {
 }
 
 src_configure() {
+       # Does not compile with -fno-common.
+       # See https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3443
+       append-cflags -fcommon
+
        local myeconfargs=(
                --enable-release-build
                $(use_enable alsa)
@@ -66,6 +70,6 @@ pkg_postinst() {
        elog "In order to use PCem, you will need some roms for various emulated systems."
        elog "You can either install globally for all users or locally for yourself."
        elog ""
-       elog "To install globally, put your ROM file into '${ROOT}/usr/share/pcem/roms/<system>'."
-       elog "To install locally, put your ROM file into '~/.pcem/roms/<system>'."
+       elog "To install globally, put your ROM files into '${ROOT}/usr/share/pcem/roms/<system>'."
+       elog "To install locally, put your ROM files into '~/.pcem/roms/<system>'."
 }