app-misc/sphinx: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 5 Apr 2020 09:09:04 +0000 (11:09 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 5 Apr 2020 09:09:23 +0000 (11:09 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
app-misc/sphinx/Manifest
app-misc/sphinx/sphinx-2.1.9.ebuild [deleted file]

index 311a7412d3d58ee934c7e20e9b086bef9193bc97..85d38a93331213a8177179b1f411c0101210f7cb 100644 (file)
@@ -1,2 +1 @@
-DIST sphinx-2.1.9-release.tar.gz 2443797 BLAKE2B d741d0bc915ece01c3ddcbfacd44f34ef5d772d2bdf07aecb3a704dc0c5ef551e9d3829af200b1c96e41be2a037552c28a83647af78e827d7a9627f1d9d536a8 SHA512 7f4538011db5d68bd00c00978d476f780fc2d355113bd2819996bacbaef90b0de5b14c946a9aad83157b818d9b6b01ee0a26bc72862cfd151067ad9967c18f56
 DIST sphinx-2.2.11-release.tar.gz 3061998 BLAKE2B 63abdf3d08046ebafcdfd67d3445325b9b127e4dd66ba9d36b3b7053ba80f1f3308b74fd1e01caae6174850e1db22c743454894584bad4a4bec78d533a002668 SHA512 cf1a262a5b0fbf0bd2827ec6ec629edeaf709ce855a6e7b509b65342baaeb26c02717ca63f1578d32c83d21e2fd6d1e92dceb34660e6351b93cd96fd4e623689
diff --git a/app-misc/sphinx/sphinx-2.1.9.ebuild b/app-misc/sphinx/sphinx-2.1.9.ebuild
deleted file mode 100644 (file)
index abc69c2..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-WANT_AUTOMAKE=1.15
-
-inherit eutils autotools toolchain-funcs
-
-#MY_P=${P/_/-}
-MY_P=${P}-release
-
-DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
-HOMEPAGE="http://www.sphinxsearch.com/"
-SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86 ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="debug id64 mysql odbc postgres stemmer syslog test xml"
-RESTRICT="!test? ( test )"
-
-RDEPEND="mysql? ( virtual/mysql )
-       postgres? ( dev-db/postgresql:* )
-       odbc? ( dev-db/unixODBC )
-       stemmer? ( dev-libs/snowball-stemmer )
-       xml? ( dev-libs/expat )
-       virtual/libiconv"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-2.0.1_beta-darwin8.patch
-
-       # drop nasty hardcoded search path breaking Prefix
-       # We patch configure directly since otherwise we need to run
-       # eautoreconf twice and that causes problems, bug 425380
-       sed -i -e 's/\/usr\/local\//\/someplace\/nonexisting\//g' configure || die
-
-       # Fix QA compilation warnings.
-       sed -i -e '19i#include <string.h>' api/libsphinxclient/test.c || die
-
-       pushd api/libsphinxclient || die
-       eautoreconf
-       popd || die
-}
-
-src_configure() {
-       # fix libiconv detection
-       use !elibc_glibc && export ac_cv_search_iconv=-liconv
-
-       econf \
-               --sysconfdir="${EPREFIX}/etc/${PN}" \
-               $(use_enable id64) \
-               $(use_with debug) \
-               $(use_with mysql) \
-               $(use_with odbc unixodbc) \
-               $(use_with postgres pgsql) \
-               $(use_with stemmer libstemmer) \
-               $(use_with syslog syslog) \
-               $(use_with xml libexpat )
-
-       cd api/libsphinxclient || die
-       econf STRIP=:
-}
-
-src_compile() {
-       emake AR="$(tc-getAR)"
-
-       emake -j 1 -C api/libsphinxclient
-}
-
-src_test() {
-       elog "Tests require access to a live MySQL database and may require configuration."
-       elog "You will find them in /usr/share/${PN}/test and they require dev-lang/php"
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-       emake DESTDIR="${D}" -C api/libsphinxclient install
-
-       dodoc doc/*
-
-       dodir /var/lib/sphinx
-       dodir /var/log/sphinx
-
-       newinitd "${FILESDIR}"/searchd.rc searchd
-
-       if use test; then
-               insinto /usr/share/${PN}
-               doins -r test
-       fi
-}