dev-util/webstorm: initial import
authorswitch87 <gert@gepe-biljarts.be>
Mon, 7 Sep 2015 07:38:57 +0000 (09:38 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 7 Sep 2015 12:31:05 +0000 (12:31 +0000)
dev-util/webstorm/Manifest [new file with mode: 0644]
dev-util/webstorm/metadata.xml [new file with mode: 0644]
dev-util/webstorm/webstorm-10.0.4.141.1550.ebuild [new file with mode: 0644]

diff --git a/dev-util/webstorm/Manifest b/dev-util/webstorm/Manifest
new file mode 100644 (file)
index 0000000..d01f2da
--- /dev/null
@@ -0,0 +1 @@
+DIST WebStorm-10.0.4.tar.gz 130242508 SHA256 f2c6b6fde74513858f204a6fc5d4f39a6b3424edcc1abc435e566ead0929319c SHA512 2523795dc3cc4395549313584e8e597b2782eb2c6ad577d0aae81b72656f00a2cc2f9bbac77f83f9e1f74350aaa762d8b7ba873558a37af316839784e506c6ec WHIRLPOOL a76ad8b92e454e12ce2948c98041a1cbc671848519a3fe329b3f6524b3bc9cb52922755668048b72011f856fadf28386ebd048830558197516029a8594a83d87
diff --git a/dev-util/webstorm/metadata.xml b/dev-util/webstorm/metadata.xml
new file mode 100644 (file)
index 0000000..3e44b6f
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+       <email>gert@gepe-biljarts.be</email>
+       <name>Gert Pellin</name>
+       <description>Proxy maintainer. Assign bugs to him.</description>
+</maintainer>
+<longdescription lang="en">
+WebStorm is a lightweight yet powerful IDE, perfectly equipped for complex client-side development and server-side development with Node.js
+</longdescription>
+</pkgmetadata>
diff --git a/dev-util/webstorm/webstorm-10.0.4.141.1550.ebuild b/dev-util/webstorm/webstorm-10.0.4.141.1550.ebuild
new file mode 100644 (file)
index 0000000..7ca3c6e
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator
+
+SLOT="$(get_major_version)"
+MY_PV="$(get_version_component_range 4-5)"
+MY_PN="WebStorm"
+
+DESCRIPTION="JavaScript IDE for complex client-side development and server-side development with Node.js"
+HOMEPAGE="http://www.jetbrains.com/webstorm"
+SRC_URI="http://download.jetbrains.com/${PN}/${MY_PN}-$(get_version_component_range 1-3).tar.gz"
+
+LICENSE="WebStorm WebStorm_Academic WebStorm_Classroom WebStorm_OpenSource WebStorm_personal"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jdk-1.7"
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_install() {
+       local dir="/opt/${PN}"
+
+       insinto "${dir}"
+       doins -r .
+       fperms 755 ${dir}/bin/{${PN}.sh,fsnotifier{,64}}
+
+       make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+}