app-shells/quoter: Version bump
authorBrian Evans <grknight@gentoo.org>
Mon, 16 Jan 2017 18:54:35 +0000 (13:54 -0500)
committerBrian Evans <grknight@gentoo.org>
Mon, 16 Jan 2017 19:01:52 +0000 (14:01 -0500)
Non-maintainer commit.  Ack by axs in IRC

Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-shells/quoter/Manifest
app-shells/quoter/quoter-3.0_p2.ebuild [new file with mode: 0644]

index 168d5dd9115baa60e906d1b34987f43788bd54d7..1fbd527b62b4ddceee857dac128008df130d0a0d 100644 (file)
@@ -1 +1,2 @@
-DIST quoter-2.0_p2.tar.gz 10108 SHA256 e1bd542b8f0bd5afaa2a7c0e21987addf7afe383ffc9e53e84a369d0e95d122b
+DIST quoter-2.0_p2.tar.gz 10108 SHA256 e1bd542b8f0bd5afaa2a7c0e21987addf7afe383ffc9e53e84a369d0e95d122b SHA512 18543b3061bbdca01c87aa3bcebd1cf69ec79e44a1f285f9ddfca4afa293e137a40e2c626dcdee15828d5777b337e6d9afbd03b7d8637bf65cc406ed5bec82a2 WHIRLPOOL 41b7440bc3b1fd174e6cfc2c3b0d43988ec07c0dd6a6ba39710c83bff379136c0dd129953de4054cabd76dab5780ba7c9b4b19ba3317c67fc8972cebdc8bb484
+DIST quoter-3.0_p2.tar.gz 10691 SHA256 19a335095991c8fa0f637c81b7e8b9a262af67e230507af87f3c113228965732 SHA512 23d77105fa05d79a7d0bcaa3f6aead25b7cb3b6f459d2740314616da587e03cd3e6b0b1e8af8f79904309bbe76603db848d42996ed7ae5ef779e27184a434fb5 WHIRLPOOL 1c083d7dc9bc8e1e4719b6e4c03087f39d4324df3aa70011e84087c7de3145f932ca3ae9fc1057b17dbe9471592c5d32ac99dff63b7962fb3c7548b31aa2a225
diff --git a/app-shells/quoter/quoter-3.0_p2.ebuild b/app-shells/quoter/quoter-3.0_p2.ebuild
new file mode 100644 (file)
index 0000000..bbba5b7
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+       emake DESTDIR="${ED}" install
+}