dev-python/hpack: Enable py3.8
authorMichał Górny <mgorny@gentoo.org>
Thu, 21 Nov 2019 20:12:11 +0000 (21:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 21 Nov 2019 21:25:06 +0000 (22:25 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hpack/hpack-3.0.0.ebuild

index 93a872a12ec6f78f3a1ec0ddd6b86de991be3887..65570c88f59dc5e3aff83265d413aaa5837b1698 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy)
 
 inherit distutils-r1
 
@@ -14,6 +14,7 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND=""
 # dev-python/pytest-relaxed causes tests to fail
@@ -33,5 +34,5 @@ python_prepare_all() {
 }
 
 python_test() {
-       py.test -vv hpack test || die "Tests fail with ${EPYTHON}"
+       pytest -vv hpack test || die "Tests fail with ${EPYTHON}"
 }