Added patch to compile with qt-3.3.5.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Tue, 20 Sep 2005 11:22:00 +0000 (11:22 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Tue, 20 Sep 2005 11:22:00 +0000 (11:22 +0000)
Package-Manager: portage-2.0.52-r1

app-cdr/k3b/ChangeLog
app-cdr/k3b/Manifest
app-cdr/k3b/files/k3b-0.12.4a-qt-3.3.5.patch [new file with mode: 0644]
app-cdr/k3b/k3b-0.12.4a.ebuild

index 610e2523b4fc41769bc0b53a38a796b5e94c32c0..e71db39f44ff6e3892ad4ae97b1fad4c8bd17922 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-cdr/k3b
 # Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.124 2005/09/20 02:13:39 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/ChangeLog,v 1.125 2005/09/20 11:22:00 flameeyes Exp $
+
+  20 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
+  +files/k3b-0.12.4a-qt-3.3.5.patch, k3b-0.12.4a.ebuild:
+  Added patch to compile with qt-3.3.5.
 
   20 Sep 2005; Caleb Tennis <caleb@gentoo.org> k3b-0.12.4a.ebuild:
   Change k3b deps to not have specific HAL and dbus version deps, per bug #105403
index 413b329d49ad1d45b74b2f2320b69fa39a62c75c..338f4c29ceb515ebc701e316bba77b51b82480a7 100644 (file)
@@ -1,8 +1,19 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 62786e3a0331a994621379ef939d3150 ChangeLog 17467
 MD5 c3794ba1b13d24f94fe2ab478c92f0ae k3b-0.11.24.ebuild 3106
-MD5 f39f4af5c0b57b1a24f1095d573b7ca1 k3b-0.12.4a.ebuild 3286
-MD5 09a576d6419cf4fdbd48757ccfab63b9 ChangeLog 17312
+MD5 7298af5d69fd3744465305319b0d0545 k3b-0.12.4a.ebuild 3333
 MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
-MD5 513df86e2c91f7c1209b63cea7d41b84 files/k3b-0.11.17-noarts.patch 893
+MD5 49d32c38a705809a2646228a8d0b71d4 files/k3b-0.12.4a-qt-3.3.5.patch 574
 MD5 a1b5a05a8513587c957d81f2f7eb44c0 files/digest-k3b-0.11.24 133
-MD5 384b07ebe51023847a4cbdb756c9e867 files/digest-k3b-0.12.4a 135
 MD5 5f469d8bb9067596d861b4a9a0a450a1 files/k3b-dvdrip-transcode.patch 1999
+MD5 513df86e2c91f7c1209b63cea7d41b84 files/k3b-0.11.17-noarts.patch 893
+MD5 384b07ebe51023847a4cbdb756c9e867 files/digest-k3b-0.12.4a 135
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDL/EOj5H05b2HAEkRAosPAJ9Cclx2JzAxbCYSn/IEgWPQeqpr0QCfXIs9
++PaXkGHsadBqhkvh1h996wM=
+=fQKn
+-----END PGP SIGNATURE-----
diff --git a/app-cdr/k3b/files/k3b-0.12.4a-qt-3.3.5.patch b/app-cdr/k3b/files/k3b-0.12.4a-qt-3.3.5.patch
new file mode 100644 (file)
index 0000000..e541555
--- /dev/null
@@ -0,0 +1,12 @@
+Index: extragear/multimedia/k3b/src/option/base_k3bdivxoptiontab.ui
+===================================================================
+--- extragear/multimedia/k3b/src/option/base_k3bdivxoptiontab.ui       (revision 460630)
++++ extragear/multimedia/k3b/src/option/base_k3bdivxoptiontab.ui       (revision 460631)
+@@ -326,7 +326,6 @@
+ </widget>
+ <layoutdefaults spacing="6" margin="11"/>
+ <includehints>
+-    <includehint>kdoublenuminput.h</includehint>
+     <includehint>knuminput.h</includehint>
+     <includehint>knuminput.h</includehint>
+     <includehint>knuminput.h</includehint>
index be2ee6df5947113b687bcb1ca70734badb831726..4d6dbb80ff5afdbcd399bb090d4b9fe1ac27075a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.4a.ebuild,v 1.3 2005/09/20 02:13:39 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k3b/k3b-0.12.4a.ebuild,v 1.4 2005/09/20 11:22:00 flameeyes Exp $
 
 inherit kde eutils flag-o-matic
 
@@ -43,6 +43,8 @@ need-kde 3.3
 
 I18N="${PN}-i18n-${PV}"
 
+PATCHES="${FILESDIR}/${P}-qt-3.3.5.patch"
+
 # These are the languages and translated documentation supported by k3b for 
 # version 0.11.x. If you are using this ebuild as a model for another ebuild 
 # for another version of K3b, DO check whether these values are different.