dev-util/bsdiff: security cleanup (bug #701848)
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 19 Mar 2020 18:31:41 +0000 (19:31 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 19 Mar 2020 18:31:53 +0000 (19:31 +0100)
Bug: https://bugs.gentoo.org/701848
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-util/bsdiff/bsdiff-4.3-r3.ebuild [deleted file]

diff --git a/dev-util/bsdiff/bsdiff-4.3-r3.ebuild b/dev-util/bsdiff/bsdiff-4.3-r3.ebuild
deleted file mode 100644 (file)
index 947b0c2..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="bsdiff: Binary Differencer using a suffix alg"
-HOMEPAGE="http://www.daemonology.net/bsdiff/"
-SRC_URI="http://www.daemonology.net/bsdiff/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD-2"
-KEYWORDS="~alpha amd64 ~arm hppa ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-DEPEND="app-arch/bzip2"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       epatch_user
-}
-
-src_compile() {
-       doecho() {
-               echo "$@"
-               "$@"
-       }
-       append-lfs-flags
-       doecho $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o bsdiff bsdiff.c -lbz2 || die "failed compiling bsdiff"
-       doecho $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o bspatch bspatch.c -lbz2 || die "failed compiling bspatch"
-}
-
-src_install() {
-       dobin bs{diff,patch}
-       doman bs{diff,patch}.1
-}