media-sound/helm: 0.9.0 version bump, EAPI-7 bump, https
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 27 Jan 2019 21:10:46 +0000 (22:10 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 27 Jan 2019 23:12:03 +0000 (00:12 +0100)
Bug: https://bugs.gentoo.org/638150
Closes: https://bugs.gentoo.org/645592
Thanks-to: Malcolm Lashley <mlashley@gmail.com>
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/helm/Manifest
media-sound/helm/files/helm-0.9.0-nomancompress.patch [new file with mode: 0644]
media-sound/helm/helm-0.9.0.ebuild [new file with mode: 0644]

index f9eace6f23d4c3bd9cc64311a47f069804ac068e..7e7894ba05e82529ead59a81e90f4dbbdac5d89e 100644 (file)
@@ -1 +1,2 @@
 DIST helm-0.4.1.tar.gz 10170154 BLAKE2B 8939a365c5cec2f1ced1d03855cc76ab532e168866b566e8adc575be8d16b9825bf1259c912c9e74f5465d68e7984a525c430cf57eb1439814d15fb38d3cf02e SHA512 093abfd47a7f3e25d168df675b8a9c067a361ae1891af208c75ec4bc02d8a30cc5de4ab2433179bcbb6074c142c8ef9b4ef11b1854fdde0551fcd340dd6b8fe0
+DIST helm-0.9.0.tar.gz 15544141 BLAKE2B 1b6811f32cf36a1c1f954cc071cd64f3dca656ee0bd420c01d0be3db516210a92adc3694ac49731cf2d7cf057a9eccf2c2dcefc14d24cf8582a3eb69efe1d0e1 SHA512 241c6bf3aec422e9ccaf7c7113eec7e30a11baadd30fe8f05f0abfac9c41d0c8a9fb284f0cae49bcaf0d3d08aa952737f6ff3eb7d48c2b2e22c60932738aeaa4
diff --git a/media-sound/helm/files/helm-0.9.0-nomancompress.patch b/media-sound/helm/files/helm-0.9.0-nomancompress.patch
new file mode 100644 (file)
index 0000000..fab3946
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/Makefile  2018-11-13 23:44:54.081925553 +0000
++++ b/Makefile    2018-11-13 23:45:34.136381471 +0000
+@@ -91,7 +91,6 @@
+       $(MAKE) clean -C builds/linux/VST CONFIG=$(CONFIG)
+ install_patches:
+-      rm -rf $(PATCHES)
+       install -d $(PATCHES)
+       cp -rf patches/* $(PATCHES)
+
+@@ -100,11 +99,8 @@
+       install standalone/builds/linux/build/$(PROGRAM) $(BIN)
+       install -m644 standalone/helm.desktop $(DESKTOP)/helm.desktop
+       install -m644 images/* $(IMAGES)
+-      cp changelog changes
+-      gzip -n -9 changelog
+-      mv changes changelog
+-      mv changelog.gz $(CHANGES)/changelog.gz
+-      cp docs/helm.1.gz $(MAN)
++      gunzip docs/helm.1.gz
++      cp docs/helm.1 $(MAN)
+ install_lv2: lv2 install_patches
+       install -d $(PATCHES) $(LV2)
diff --git a/media-sound/helm/helm-0.9.0.ebuild b/media-sound/helm/helm-0.9.0.ebuild
new file mode 100644 (file)
index 0000000..5ca5602
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+DESCRIPTION="Open source polyphonic software synthesizer with lots of modulation"
+HOMEPAGE="https://tytel.org/helm/"
+SRC_URI="https://github.com/mtytel/helm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       media-libs/alsa-lib
+       media-libs/freetype
+       media-libs/lv2
+       virtual/jack
+       virtual/opengl
+       x11-libs/libX11
+       x11-libs/libXcursor
+       x11-libs/libXext
+       x11-libs/libXinerama
+       x11-libs/libXrandr"
+RDEPEND="${DEPEND}
+       !app-admin/helm
+"
+
+DOCS=( changelog README.md )
+
+PATCHES=( "${FILESDIR}/${P}-nomancompress.patch" )
+
+src_prepare() {
+       default
+       sed -e "s|/usr/lib/|/usr/$(get_libdir)/|" -i Makefile || die
+}
+
+src_compile() {
+       emake PREFIX=/usr all
+}
+
+src_install() {
+       default
+       make_desktop_entry /usr/bin/helm Helm /usr/share/helm/icons/helm_icon_32_1x.png
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}