net-ftp/ftpbase: Utilize {group,user}/ftp
authorMichał Górny <mgorny@gentoo.org>
Thu, 30 May 2019 12:12:07 +0000 (14:12 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 24 Jun 2019 10:29:32 +0000 (12:29 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-ftp/ftpbase/ftpbase-0.01-r3.ebuild [new file with mode: 0644]

diff --git a/net-ftp/ftpbase/ftpbase-0.01-r3.ebuild b/net-ftp/ftpbase/ftpbase-0.01-r3.ebuild
new file mode 100644 (file)
index 0000000..c333840
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils pam user
+
+DESCRIPTION="FTP layout package"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="pam"
+
+DEPEND="pam? ( virtual/pam )
+       !<net-ftp/proftpd-1.2.10-r6
+       !<net-ftp/pure-ftpd-1.0.20-r2
+       !<net-ftp/vsftpd-2.0.3-r1"
+RDEPEND="
+       acct-group/ftp
+       acct-user/ftp"
+
+S=${WORKDIR}
+
+src_install() {
+       # The ftpusers file is a list of people who are NOT allowed
+       # to use the ftp service.
+       insinto /etc
+       doins "${FILESDIR}/ftpusers" || die
+
+       cp "${FILESDIR}/ftp-pamd-include" "${T}" || die
+       if use elibc_FreeBSD; then
+               sed -i -e "/pam_listfile.so/s/^.*$/account  required  pam_ftpusers.so no_warn disallow/" \
+                       "${T}"/ftp-pamd-include || die
+       fi
+       newpamd "${T}"/ftp-pamd-include ftp
+}