dev-python/oslo-middleware: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 18:29:28 +0000 (12:29 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:05:58 +0000 (13:05 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-middleware/Manifest
dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild [deleted file]

index cdf7bd39b5fd2059af99c051399048ddd0ce02a0..00abe66e7222f17879df837f20c239f403008329 100644 (file)
@@ -1,2 +1 @@
-DIST oslo.middleware-3.34.0.tar.gz 55582 BLAKE2B 0e1af09d016cd5b81c5e0e719d40665ce24e0caaf28a4aae0043f99eee4e74a36669fdaa39330d0ffa13b588892480ee5081e1ffa41b431687c85964c7f30460 SHA512 ba8b418eb11f25ca929db32eb0451fdba757197e1bdba90dd56665e08daaa6f0a4dc6cc07788db4f14ebf2625312d3db69b73acc5cb425fa9e35299f22b6d451
 DIST oslo.middleware-3.37.1.tar.gz 56354 BLAKE2B e9b119d2163c3949eb98b7580b4d5aa4a4427b9a8b3a841549f282358d8daefe62cc3f0588535c744aab7b77b44d38691316f50b9d60e5c974e3a0714a367699 SHA512 1864b2c25602ac7e27e2b080617f7af5f38083705735893dde744e7535d127d62ab0f29a0ef2575ec53af22969544d83e454bc5913b5719c4eb7d312764fa5c0
diff --git a/dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild b/dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild
deleted file mode 100644 (file)
index d4dc188..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Components injected into wsgi pipelines to intercept request/response flows."
-HOMEPAGE="https://pypi.org/project/oslo.middleware/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.middleware/oslo.middleware-${PV}.tar.gz"
-S="${WORKDIR}/oslo.middleware-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
-               !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
-               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
-       )"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
-       !~dev-python/jinja-2.9.0[${PYTHON_USEDEP}]
-       !~dev-python/jinja-2.9.1[${PYTHON_USEDEP}]
-       !~dev-python/jinja-2.9.2[${PYTHON_USEDEP}]
-       !~dev-python/jinja-2.9.3[${PYTHON_USEDEP}]
-       !~dev-python/jinja-2.9.4[${PYTHON_USEDEP}]
-       >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
-       >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
-       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/statsd-3.2.1[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests tests/ || die "test failed under ${EPYTHON}"
-}