x11-misc/bbppp: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:13 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 24 Dec 2019 17:40:13 +0000 (18:40 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
x11-misc/bbppp/files/bbppp-0.2.5-gcc3-multiline.patch
x11-misc/bbppp/files/bbppp-asneeded.patch

index ec064c74c16fb01f52b95769a9b863e50b84e710..a8e1a0cdbba4e8a3aa7c037c133c91954d5cdcd7 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit autotools eutils
+inherit autotools
 
 DESCRIPTION="blackbox ppp frontend/monitor"
 HOMEPAGE="https://sourceforge.net/projects/bbtools/"
@@ -12,30 +12,34 @@ SRC_URI="mirror://sourceforge/bbtools/${PN}/${P}/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ppc x86"
-IUSE=""
 
 DEPEND="x11-libs/libX11"
 RDEPEND="${DEPEND}
        media-fonts/font-adobe-100dpi"
 
-DOCS=( README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbppp )
+PATCHES=(
+       "${FILESDIR}"/${P}-gcc3-multiline.patch
+       "${FILESDIR}"/${PN}-asneeded.patch
+       "${FILESDIR}"/${P}-overflows.patch
+)
 
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-gcc3-multiline.patch \
-               "${FILESDIR}"/${PN}-asneeded.patch \
-               "${FILESDIR}"/${P}-overflows.patch
+       default
+       mv configure.{in,ac} || die
        eautoreconf
 }
 
-src_install () {
+src_install() {
        default
-       rm "${D}"/usr/share/bbtools/README.bbppp
+       dodoc BUGS data/README.bbppp
+
+       rm "${ED}"/usr/share/bbtools/README.bbppp || die
 }
 
 pkg_postinst() {
        # don't assume blackbox exists because virtual/blackbox is installed
-       if [[ -x ${ROOT}/usr/bin/blackbox ]] ; then
-               if ! grep bbppp "${ROOT}"/usr/bin/blackbox &>/dev/null ; then
+       if [[ -x ${EROOT}/usr/bin/blackbox ]] ; then
+               if ! grep bbppp "${EROOT}"/usr/bin/blackbox &>/dev/null ; then
                        sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
                fi
        fi
index ef2072faa9af51dc0815f9fa95cade410d01a4a0..1aff6b167847fb0d2718771821ba9986d9970b46 100644 (file)
@@ -1,5 +1,5 @@
---- main.cc
-+++ main.cc
+--- a/main.cc
++++ b/main.cc
 @@ -24,25 +24,24 @@
  
  void Usage()
@@ -19,7 +19,7 @@
 -                            -com[pact]                  Display buttons in compact style\n\
 -                            -notime                     Dont display time window\n\
 -                            -nosecs                     Show uptime in old-style hh:mm format\n\n"};
-+      char* usageOptions = {"Options:\n"
++      const char* usageOptions = {"Options:\n"
 +                           "-display <display name>     X server to connect to\n"
 +                           "-c[onfig] <filename>        Alternate config file\n"
 +                           "-n[obb]                     Fall back on default configuration\n"
index 7e8c2b8bcfd40097bfc157529e36a155475e4f8a..5feb8bcd11c0282ca1a2b6f8c017927a2a3ae014 100644 (file)
@@ -2,8 +2,8 @@ Fixing build with as-needed
 
 https://bugs.gentoo.org/show_bug.cgi?id=248552
 
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
 @@ -86,14 +86,9 @@
  AC_PATH_X
  AC_PATH_XTRA
@@ -21,8 +21,8 @@ https://bugs.gentoo.org/show_bug.cgi?id=248552
  
  dnl Checks for header files.
  AC_HEADER_STDC
---- Makefile.am
-+++ Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
 @@ -1,4 +1,4 @@
 -CPPFLAGS =    @CPPFLAGS@ @INTERLACE@ @ISDN@\
 +AM_CPPFLAGS =  @INTERLACE@ @ISDN@\