New nightlie.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Tue, 6 Jun 2006 08:46:34 +0000 (08:46 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Tue, 6 Jun 2006 08:46:34 +0000 (08:46 +0000)
Package-Manager: portage-2.1_rc4-r3

media-sound/mt-daapd/ChangeLog
media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1197 [new file with mode: 0644]
media-sound/mt-daapd/mt-daapd-0.3.0_pre1197.ebuild [new file with mode: 0644]

index 2069feabecf23e9db3c3bc49bf821831fde073ef..465b0b76a244b2f6d2829b826de3ebbf76ee0d42 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/mt-daapd
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.32 2006/06/01 20:18:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.33 2006/06/06 08:46:34 flameeyes Exp $
+
+*mt-daapd-0.3.0_pre1197 (06 Jun 2006)
+
+  06 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+  -mt-daapd-0.3.0_pre1171.ebuild, +mt-daapd-0.3.0_pre1197.ebuild:
+  New nightlie.
 
 *mt-daapd-0.3.0_pre1171 (01 Jun 2006)
 
diff --git a/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1197 b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1197
new file mode 100644 (file)
index 0000000..db92613
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 25d8ea8fe16269c7c5940aab61d3383f mt-daapd-svn-1197.tar.gz 1139080
+RMD160 29c385c113853c97f2f6a5624d02d9dc1c0e061c mt-daapd-svn-1197.tar.gz 1139080
+SHA256 8f44db0c21ddaa635cc0bb2c362fb7a91d3b0135cdf817a8c3faca11bc538063 mt-daapd-svn-1197.tar.gz 1139080
diff --git a/media-sound/mt-daapd/mt-daapd-0.3.0_pre1197.ebuild b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1197.ebuild
new file mode 100644 (file)
index 0000000..f5e6850
--- /dev/null
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.3.0_pre1197.ebuild,v 1.1 2006/06/06 08:46:34 flameeyes Exp $
+
+inherit eutils flag-o-matic base
+
+SVN="${PV#*pre}"
+
+if [[ -n ${SVN} ]] ; then
+       MY_P="${PN}-svn-${SVN}"
+       SRC_URI="http://nightlies.mt-daapd.org/${MY_P}.tar.gz"
+else
+       MY_P="${P/_/-}"
+       SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
+HOMEPAGE="http://www.mt-daapd.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~sparc ~x86"
+IUSE="howl vorbis avahi sqlite3 flac ffmpeg"
+
+DEPEND="sys-libs/zlib
+       media-libs/libid3tag
+       !sqlite3? ( =dev-db/sqlite-2* )
+       sqlite3? ( =dev-db/sqlite-3* )
+       howl? ( !avahi? ( >=net-misc/howl-0.9.2 )
+               avahi? ( net-dns/avahi ) )
+       vorbis? ( media-libs/libvorbis )
+       flac? ( media-libs/flac )
+       ffmpeg? ( media-video/ffmpeg )"
+
+pkg_setup() {
+       if use howl && use avahi && ! built_with_use net-dns/avahi howl-compat; then
+               eerror "You requested avahi support, but this package requires"
+               eerror "the howl-compat support enabled in net-dns/avahi to work"
+               eerror "with it."
+               eerror
+               eerror "Please recompile net-dns/avahi with +howl-compat."
+               die "Missing howl-compat support in avahi."
+       fi
+}
+
+src_compile() {
+       local myconf=""
+       local howlincludes
+
+       append-flags -fno-strict-aliasing
+
+       # howl support?
+       if use howl; then
+               use avahi && \
+                       howlincludes="/usr/include/avahi-compat-howl" || \
+                       howlincludes="/usr/include/howl"
+
+               myconf="${myconf}
+                       --enable-howl
+                       --with-howl-libs=/usr/$(get_libdir)
+                       --with-howl-includes=${howlincludes}"
+       fi
+
+       # Bug 65723
+       if use vorbis; then
+               myconf="${myconf} --enable-oggvorbis"
+       fi
+
+       econf \
+               $(use_enable vorbis oggvorbis) \
+               $(use_enable flac) \
+               $(use_enable !sqlite3 sqlite) \
+               $(use_enable sqlite3) \
+               $(use_enable ffmpeg) \
+               --with-ffmpeg-includes=${ROOT}/usr/include/ffmpeg \
+               ${myconf} || die "configure failed"
+       emake || die "make failed"
+
+       cp ${FILESDIR}/${PN}.init.2 ${WORKDIR}/initd
+       if ! use howl; then
+               sed -i -e '/#USEHOWL/d' ${WORKDIR}/initd
+       elif ! use avahi; then
+               sed -i -e 's:#USEHOWL ::' ${WORKDIR}/initd
+       else
+               sed -i -e 's:#USEHOWL ::; s:mDNSResponder:avahi-daemon:' ${WORKDIR}/initd
+       fi
+}
+
+src_install() {
+       make DESTDIR=${D} install || die "make install failed"
+
+       insinto /etc
+       newins ${FILESDIR}/mt-daapd.conf.example mt-daapd.conf.example
+       doins contrib/mt-daapd.playlist
+
+       newinitd ${WORKDIR}/initd ${PN}
+
+       keepdir /var/cache/mt-daapd /etc/mt-daapd.d
+
+       dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+       einfo
+       einfo "You have to configure your mt-daapd.conf following"
+       einfo "/etc/mt-daapd.conf.example file."
+       einfo
+
+       if use howl; then
+               use avahi && \
+                       howlservice="avahi-daemon" || \
+                       howlservice="mDNSResponder"
+
+               einfo
+               einfo "Since you want to use howl instead of the internal mdnsd"
+               einfo "you need to make sure that you have ${howlservice} configured"
+               einfo "and running to use mt-daapd."
+               einfo
+
+               if use avahi; then
+                       einfo "Avahi support is currently experimental, it does not work"
+                       einfo "as intended when using more than one mt-daapd instance."
+                       einfo "If you want to run more than one mt-daapd, just use the"
+                       einfo "internal mdnsd by building with -howl flag."
+               fi
+       fi
+
+       if use vorbis; then
+               einfo
+               einfo "You need to edit you extensions list in /etc/mt-daapd.conf"
+               einfo "if you want your mt-daapd to serve ogg files."
+               einfo
+       fi
+
+       einfo
+       einfo "If you want to start more than one ${PN} service, symlink"
+       einfo "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
+       einfo "load the data from /etc/${PN}.d/<name>.conf."
+       einfo "Make sure that you have different cache directories for them."
+       einfo
+}