sys-devel/clang: Fix incorrect +x on scan-build.1 manpage
authorMichał Górny <mgorny@gentoo.org>
Thu, 6 Apr 2017 07:42:44 +0000 (09:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 6 Apr 2017 12:47:56 +0000 (14:47 +0200)
sys-devel/clang/clang-4.0.0-r1.ebuild
sys-devel/clang/clang-9999.ebuild

index b8ce12c11d4d76ced4e350dd26a19cd0e5134c46..703190f0bf5eb446bf0081294fdb34129a429920 100644 (file)
@@ -296,4 +296,6 @@ multilib_src_install_all() {
        docompress "/usr/lib/llvm/${SLOT}/share/man"
        # match 'html' non-compression
        use doc && docompress -x "/usr/share/doc/${PF}/tools-extra"
+       # +x for some reason; TODO: investigate
+       use static-analyzer && fperms a-x "/usr/lib/llvm/${SLOT}/share/man/man1/scan-build.1"
 }
index cd95492a02c5bd4ce4ee0285714f28a9f4ad6eb2..c28114fd1a917cf226902d433111e0946cbdd800 100644 (file)
@@ -293,4 +293,6 @@ multilib_src_install_all() {
        docompress "/usr/lib/llvm/${SLOT}/share/man"
        # match 'html' non-compression
        use doc && docompress -x "/usr/share/doc/${PF}/tools-extra"
+       # +x for some reason; TODO: investigate
+       use static-analyzer && fperms a-x "/usr/lib/llvm/${SLOT}/share/man/man1/scan-build.1"
 }