app-text/nuspell: Improve integration of tests
authorSebastian Pipping <sping@gentoo.org>
Thu, 6 Feb 2020 17:55:26 +0000 (18:55 +0100)
committerSebastian Pipping <sping@gentoo.org>
Thu, 6 Feb 2020 17:56:42 +0000 (18:56 +0100)
Upstream: https://github.com/nuspell/nuspell/issues/51#issuecomment-583019563
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

app-text/nuspell/nuspell-3.0.0.ebuild

index b5874aeda40cc916cadbd7a6547a7272a44b103a..911f390e6d2fbdda371aa32dcc2bc99a79c3bd1e 100644 (file)
@@ -9,10 +9,10 @@ DESCRIPTION="Spell checker library and CLI for complex natural languages"
 HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
 SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
-LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ ) LGPL-3+"
+LICENSE="test? ( || ( MPL-1.1 GPL-2+ LGPL-2.1+ ) ) LGPL-3+"
 SLOT="0/3"  # due to libnuspell.so.3
 KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE="doc test"
 
 RDEPEND="dev-libs/icu"
 DEPEND="${RDEPEND}
@@ -21,6 +21,16 @@ DEPEND="${RDEPEND}
 
 DOCS=( CHANGELOG.md )
 
+RESTRICT="!test? ( test )"
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_TESTING=$(usex test)
+       )
+
+       cmake_src_configure
+}
+
 pkg_postinst() {
        einfo
        einfo 'Nuspell needs language packs and/or dictionaries to be of use'