*/*: Switch gnome proj to cmake.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 4 Jan 2020 10:41:54 +0000 (11:41 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 4 Jan 2020 12:11:05 +0000 (13:11 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/libgit2/libgit2-0.28.4.ebuild
gui-libs/libwpe/libwpe-1.4.0.1.ebuild
gui-libs/wpebackend-fdo/wpebackend-fdo-1.4.0.ebuild

index 48c712484567f517a71fefeb2c01c1c753e68e61..c88d84762df87c4a7148cc996fd7d3655880db23 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
@@ -46,7 +46,7 @@ src_configure() {
                -DUSE_SSH=$(usex ssh)
                -DTHREADSAFE=$(usex threads)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_test() {
@@ -56,12 +56,12 @@ src_test() {
                ewarn "Skipping tests: non-root privileges are required for all tests to pass"
        else
                local TEST_VERBOSE=1
-               cmake-utils_src_test -R offline
+               cmake_src_test -R offline
        fi
 }
 
 src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        dodoc docs/*.{md,txt}
 
        if use examples ; then
index c499b99ae51b856eda7294e93b598b8e869aec6c..402fdf1db442726209c11f34b4c579ee2293f056 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="Platform-agnostic interfaces for WPE WebKit"
 HOMEPAGE="https://wpewebkit.org/"
@@ -29,5 +29,5 @@ src_configure() {
                -DBUILD_DOCS=OFF # hotdoc not packaged
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index 86b60c4026f6b3c2c9da3b070fa38b51479ecd09..062bcbc68fa9f200cba9e90bc1f1766a75ffef88 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils
+inherit cmake
 
 DESCRIPTION="WPE backend designed for Linux desktop systems"
 HOMEPAGE="https://wpewebkit.org/"
@@ -35,5 +35,5 @@ src_configure() {
                -DBUILD_DOCS=OFF # hotdoc not packaged
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }