dev-python/pykka: Bump to 2.0.2, py3.7
authorMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 09:08:54 +0000 (10:08 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 09:33:59 +0000 (10:33 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pykka/Manifest
dev-python/pykka/pykka-2.0.2.ebuild [new file with mode: 0644]

index 2ea717670b799e07781e81109cb202de2fa0e077..bf4cddfd42780edf73dd79816c5150005ac37690 100644 (file)
@@ -1 +1,2 @@
 DIST Pykka-1.2.1.tar.gz 46252 BLAKE2B 48d351924874c3a26436643aef1bdeede1dc008b1edad67a4dca5aa29b13d421fd1643d1e9ec23bbe9ba16e638911b382389df878a2b53f7826ebf3d9058adaf SHA512 22eaa735915e33146d8a3fa3f9dd5ea1dd608e7ad45ab21721a108b01ddf058b4cd00da67b762a95ede650c9ba1a79ee3d6fd22a491bc7ff348a56b7c0139cfd
+DIST Pykka-2.0.2.tar.gz 51858 BLAKE2B 62132a3ded257d44d9504258418abc73ec9cc09353ab8e1948c9910fc11f67f770510b2dc7cf122db9af9ff62091757b648dce69cbdab0ffc17567169749d0d2 SHA512 98b2e6122dc5158da489265cf7cf9e358bfa432d0a0eaab9f50a07c0050083afb19aad494e4cd27347c376947eafb7d9796909c18e3648ef1bf0685bd6384e5b
diff --git a/dev-python/pykka/pykka-2.0.2.ebuild b/dev-python/pykka/pykka-2.0.2.ebuild
new file mode 100644 (file)
index 0000000..f438558
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="https://www.pykka.org/en/latest/ https://github.com/jodal/pykka"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+       test? (
+               dev-python/eventlet[${PYTHON_USEDEP}]
+               dev-python/gevent[${PYTHON_USEDEP}]
+               dev-python/pytest-mock[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest