dev-python/flask-themes: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:31 +0000 (17:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:31 +0000 (17:12 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
dev-python/flask-themes/flask-themes-0.1.3_p20180112.ebuild

index c51b0bfa94e9b61c06771ba9cb0b6b27e5b8ba12..1da73c8360cb01922cb781bbf877d53f493da11f 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit distutils-r1
 
@@ -17,6 +17,8 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE=""
+# suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
+RESTRICT="test"
 
 RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
@@ -25,10 +27,3 @@ DEPEND="${RDEPEND}
 S="${WORKDIR}/${MY_P}"
 
 PATCHES=( "${FILESDIR}"/fixtests.patch )
-
-python_test() {
-       # suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
-       if ! python_is_python3; then
-               PYTHONPATH=.:tests nosetests || die "Tests failed under ${EPYTHON}"
-       fi
-}
index 28897c00b361c583263f1b5c85f9cf1ab72d3a38..870aff1c16d275ad82204260c1478d20b6b0de2c 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( pypy3 python3_{5,6,7} )
 
 inherit distutils-r1