dev-python/pip: Remove unnecessary test deps and restrictions
authorMichał Górny <mgorny@gentoo.org>
Sun, 24 Nov 2019 18:34:56 +0000 (19:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 24 Nov 2019 19:31:44 +0000 (20:31 +0100)
Remove pytest version restriction, pytest-4 gives the same result.
Remove unused pytest-cov.  Remove unnecessary pytest-rerunfailures
and pytest-timeout (they do not affect the result).  Finally, remove
pytest-xdist -- while tests are obviously slower without it, it's very
unstable and frequently causes crash before tests even start.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pip/pip-19.3.1-r1.ebuild

index 5db9420caa27ac9dd3a3afaa07523bee9f5ff107..b0232bd55f9a4f9eec0286b1e4dceba1d1fe3395 100644 (file)
@@ -40,11 +40,7 @@ DEPEND="
                dev-python/freezegun[${PYTHON_USEDEP}]
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pretend[${PYTHON_USEDEP}]
-               <dev-python/pytest-4[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               <dev-python/pytest-rerunfailures-7.0[${PYTHON_USEDEP}]
-               dev-python/pytest-timeout[${PYTHON_USEDEP}]
-               <dev-python/pytest-xdist-1.28.0[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/pyyaml[${PYTHON_USEDEP}]
                dev-python/scripttest[${PYTHON_USEDEP}]
                dev-python/virtualenv[${PYTHON_USEDEP}]
@@ -92,8 +88,6 @@ python_test () {
                # version_check tests are excluded since we explicitly disable this feature entirely.
                # uninstall test just fails, likely because of our test environment setup.
                python -m pytest -v \
-                       -n $(makeopts_jobs) \
-                       --timeout 300 \
                        -k "not (svn or git or bazaar or mercurial or version_check or uninstall_non_local_distutils ${EXCLUDE_TESTS[*]})" \
                        -m "not network" \
                        || die