mate-base/libmatekbd: Bump to 1.24.0
authorAdam Feldman <NP-Hardass@gentoo.org>
Wed, 4 Mar 2020 19:33:34 +0000 (14:33 -0500)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:47:55 +0000 (13:47 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
mate-base/libmatekbd/Manifest
mate-base/libmatekbd/libmatekbd-1.24.0.ebuild [new file with mode: 0644]

index 547d33de467c9f8e54246d417a8f46344459e990..b52bfab58a9a691dd7c28d6aafef144049abb3f7 100644 (file)
@@ -1,2 +1,3 @@
 DIST libmatekbd-1.18.2.tar.xz 369448 BLAKE2B 25f588dec8926b63f19fb62fc10a3e188c8692875a4dd7c65cd97957aa02e22f33d68644d564e02f114f1f42c818bf09625463086569b97824ed561741aba9c9 SHA512 97971fc406fac09e0a652ccb5f811194eeff695a4a8b093b24225230cb64ceebd221d91aab071b0ca7ffd20b1b38e13d428d68fc8249101a3b3f8342fbb1f71e
 DIST libmatekbd-1.22.0.tar.xz 374604 BLAKE2B 318c26cd6630773b0b1e89769e8b540545500d5bcc359e568d8cea0ffccebd17a1dd248cc8f61ba584058cb170171608f6c729256eb7936e8b23738657d5a9a5 SHA512 79f19455bb6c0df5a50e445907ac12d6bd92a54cd086e0303890bc67350de3d94b2fd665efdaec85f84a42d76af430ad0a1b9639da078179ac25d27c4a325281
+DIST libmatekbd-1.24.0.tar.xz 425720 BLAKE2B 6f5f808f55c57c3d651d5c871a5f95269397a6d1c2e3cd37d2b16a5519300a81e994e0ac10bf474b9860ec7c0f3c862332199e10c506f38107c7f7d791899b4d SHA512 6a04f4f38ac1d1ef372fdbaddfe4c935d79039cce1a3d68a6876fa5550556f1d568de1d53857531c6f0bd5994e815f2c9e5be0436218e97718f87e17973ea655
diff --git a/mate-base/libmatekbd/libmatekbd-1.24.0.ebuild b/mate-base/libmatekbd/libmatekbd-1.24.0.ebuild
new file mode 100644 (file)
index 0000000..8fa3f56
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE keyboard configuration library"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="X +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-libs/glib-2.50:2
+       virtual/libintl
+       x11-libs/cairo
+       >=x11-libs/gdk-pixbuf-2.24:2
+       x11-libs/libX11
+       >=x11-libs/libxklavier-5.2:0[introspection?]
+       x11-libs/pango
+       >=x11-libs/gtk+-3.22:3[introspection?]
+       introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
+
+DEPEND="${RDEPEND}
+       dev-libs/libxml2
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig"
+
+src_configure() {
+       mate_src_configure \
+               $(use_with X x) \
+               $(use_enable introspection) \
+               $(use_enable test tests)
+}