dev-db/pgagent: Bump to 4.0.0
authorAaron W. Swenson <titanofold@gentoo.org>
Sat, 22 Jun 2019 10:32:54 +0000 (06:32 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Sat, 22 Jun 2019 10:33:01 +0000 (06:33 -0400)
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
dev-db/pgagent/Manifest
dev-db/pgagent/pgagent-4.0.0.ebuild [new file with mode: 0644]

index b4f6ba3e7fbbc0b55e06fafde6ab8bc688b05141..a8365d4f8d376278507e3bb4c5353057d227b319 100644 (file)
@@ -1 +1,2 @@
 DIST pgAgent-3.4.0-Source.tar.gz 45081 BLAKE2B 81f074213285253743127188d9e203cb01d8492ce502dc5215279c7c557fdd7f532fa383a4578a8d9cc8ea46668ea971015e4cc5989d1b8022ed8924a92b988b SHA512 3b068fc6f5e51ff20604f8cec3e067d04b5b1537229da15ee442000f5fe834697a4eae86be0e9a58b8ee5da24cc985c8c9804d71cb2a50e93ec4cf9a424a4ff0
+DIST pgAgent-4.0.0-Source.tar.gz 63561 BLAKE2B 1731e748a6a5e76cd8b177162eb5b82ae633d1b507739e3193a8857a0eee0fe775fdaadb871eb5d708c0f7e80558680b5d7d246f4cb5d2bc1c10955bdf9cc09e SHA512 df2d6f5817d83d4cf60f0f1106718225870bcfd2f5b882765e5fd459e1614208225f90b29de492bec5284f3727f3d4be9f724b92ef503fea08029fab22a8fbb4
diff --git a/dev-db/pgagent/pgagent-4.0.0.ebuild b/dev-db/pgagent/pgagent-4.0.0.ebuild
new file mode 100644 (file)
index 0000000..19115c2
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils user
+
+MY_PN=${PN/a/A}
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="${MY_PN} is a job scheduler for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/download/pgagent-source-code/"
+SRC_URI="mirror://postgresql/pgadmin/${PN}/${MY_PN}-${PV}-Source.tar.gz"
+
+LICENSE="POSTGRESQL GPL-2"
+SLOT="0"
+
+RDEPEND="dev-db/postgresql:*
+               dev-libs/boost
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}-Source"
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       sed -e "s:share):share/${P}):" \
+               -i CMakeLists.txt || die "failed to patch CMakeLists.txt"
+}
+
+src_configure() {
+       mycmakeargs=( "-DSTATIC_BUILD:BOOLEAN=FALSE"
+                                  )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       newinitd "${FILESDIR}/pgagent.initd-r1" "${PN}"
+       newconfd "${FILESDIR}/pgagent.confd" "${PN}"
+
+       rm "${ED}"/usr/{LICENSE,README} || die "failed to remove useless docs"
+}
+
+pkg_preinst() {
+       # This user needs a real shell, and the daemon will use the
+       # ~/.pgpass file from its home directory.
+       enewuser pgagent -1 /bin/bash /home/pgagent
+}