dev-python/argh: python3_6 added
authorAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 12:56:12 +0000 (19:56 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 12:56:12 +0000 (19:56 +0700)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/argh/argh-0.26.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/argh/argh-0.26.2-r1.ebuild b/dev-python/argh/argh-0.26.2-r1.ebuild
new file mode 100644 (file)
index 0000000..9cc6202
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 63af6434dd2b62e30b4853bcb9a6d8bfe13fead3 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="http://packages.python.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/iocapture[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+               ${RDEPEND}
+       )"
+
+python_test() {
+       py.test || die "Tests fail with ${EPYTHON}"
+}