dev-util/lxqt-build-tools: add version 0.7.0
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 16:30:03 +0000 (19:30 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:26 +0000 (01:28 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/lxqt-build-tools/Manifest
dev-util/lxqt-build-tools/lxqt-build-tools-0.7.0.ebuild [new file with mode: 0644]

index 61ae07bc89bf96b7869baf5a2bfb353f96cebd6d..04026408a0e656c8f1c02cafe99d5af4f96fcb80 100644 (file)
@@ -1 +1,2 @@
 DIST lxqt-build-tools-0.6.0.tar.xz 22520 BLAKE2B 99e8032e111f776708d0a84e65db6534f517e75803d2cf747618889dccc46e9d55caa0ba3c89c88d56143a69ced015df9f1eae68a34c7ea050c6f97aedcf0f33 SHA512 f95c47d40f26defa8bc4e13a0449428945c282cb5e2201610e9529bfd5154a438ee9dcc4f556bd76efe13b97533bbed2f49ab5c100225907781093094a692227
+DIST lxqt-build-tools-0.7.0.tar.xz 24436 BLAKE2B b3bc9a62c530e682cff5412400d0fb14958d6aabddaef8c76b0073b01d356a9e7b227436428a3810f6b442dd77e57f4efb080a4902261679ad2c7898cf3098cb SHA512 7b6fd30e6ae8355ae36be55f8f7d47d78f507c11ebd9cbdd1d2ce5f14db68b845ad0bb8ca05fa1122bfd4c41f6dc792dff5100dcb8e61167517c3704527c7cde
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.7.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..ce1e2b0
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+       >=dev-libs/glib-2.50.0
+       dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"