Remove unused version.
authorSamuli Suominen <ssuominen@gentoo.org>
Mon, 19 Feb 2007 20:57:10 +0000 (20:57 +0000)
committerSamuli Suominen <ssuominen@gentoo.org>
Mon, 19 Feb 2007 20:57:10 +0000 (20:57 +0000)
Package-Manager: portage-2.1.2-r9

x11-misc/rss-glx/files/digest-rss-glx-0.8.1-r3 [deleted file]
x11-misc/rss-glx/rss-glx-0.8.1-r3.ebuild [deleted file]
x11-misc/xscreensaver/files/digest-xscreensaver-5.00-r1 [deleted file]
x11-misc/xscreensaver/xscreensaver-5.00-r1.ebuild [deleted file]

diff --git a/x11-misc/rss-glx/files/digest-rss-glx-0.8.1-r3 b/x11-misc/rss-glx/files/digest-rss-glx-0.8.1-r3
deleted file mode 100644 (file)
index 415a068..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a2bdf0e10ee4e89c8975f313c5c0ba6f rss-glx_0.8.1.tar.bz2 5248755
-RMD160 c12e91be3505129ca1e4d877309e53505b4a8f4e rss-glx_0.8.1.tar.bz2 5248755
-SHA256 cf03409ed82f167b39a37b25d21a2de065bb728afeda561bdb2626e7b7ea42bb rss-glx_0.8.1.tar.bz2 5248755
diff --git a/x11-misc/rss-glx/rss-glx-0.8.1-r3.ebuild b/x11-misc/rss-glx/rss-glx-0.8.1-r3.ebuild
deleted file mode 100644 (file)
index 559209c..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rss-glx/rss-glx-0.8.1-r3.ebuild,v 1.4 2007/01/03 13:32:24 kloeri Exp $
-
-inherit flag-o-matic eutils
-
-MY_P=${PN}_${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="Really Slick Screensavers using OpenGL for XScreenSaver"
-HOMEPAGE="http://rss-glx.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="kde sse 3dnow openal xscreensaver"
-
-RDEPEND="|| ( x11-libs/libXt virtual/x11 )"
-DEPEND="${RDEPEND}
-       virtual/opengl
-       media-libs/glew
-       >=media-gfx/imagemagick-5.5.7
-       kde? ( || ( kde-base/kdeartwork-kscreensaver kde-base/kdeartwork ) )
-       !kde? ( >=x11-misc/xscreensaver-4.22-r2 )
-       xscreensaver? ( >=x11-misc/xscreensaver-4.22-r2 )
-       openal? ( media-libs/openal )"
-
-pkg_setup() {
-       if use kde && use xscreensaver ; then
-               for pkg in kde-base/kdeartwork-kscreensaver kde-base/kdeartwork ; do
-                       if has_version ${pkg} && ! built_with_use ${pkg} xscreensaver ; then
-                               eerror "rss-glx wont work nicely with kde unless you"
-                               eerror "emerge ${pkg} with USE=xscreensaver."
-                               eerror "See http://bugs.gentoo.org/show_bug.cgi?id=88212"
-                               die "Please re-emerge ${pkg} with USE=xscreensaver"
-                       fi
-               done
-       fi
-}
-
-src_unpack() {
-       unpack ${A}
-       cd ${S}
-       epatch ${FILESDIR}/${P}-r1-gentoo.patch
-       epatch ${FILESDIR}/${PN}-0.8.1-hyperspace-viewport.patch
-       cp ${FILESDIR}/jwz-vroot.h ${S}/include/vroot.h
-}
-
-src_compile() {
-       filter-flags -fPIC
-
-       local myconf
-
-       myconf="${myconf} --bindir=/usr/lib/misc/xscreensaver" \
-       myconf="${myconf} --with-configdir=/usr/share/xscreensaver/config/" \
-
-       if use kde; then
-               find . -name '*.desktop' -exec \
-                       sed -i \
-                               -e 's:Exec=kxsrun \(.*\):Exec=kxsrun \1:g' \
-                               -e 's:Exec=kxsconfig \(.*\):Exec=kxsconfig \1:g' \
-                               '{}' \
-                       \; \
-                       || die "couldnt sed desktop files"
-               myconf="${myconf} --with-kdessconfigdir=/usr/share/applications/"
-       fi
-
-       econf \
-               $(use_enable openal sound) \
-               $(use_enable sse) \
-               $(use_enable 3dnow) \
-               ${myconf} || die "econf failed"
-       emake || die "emake failed"
-}
-
-src_install() {
-       make DESTDIR=${D} install || die "install failed"
-       dodoc README README.xscreensaver
-
-       # symlink to satisfy kde's kxs*
-       use kde && dosym /usr/share/control-center/screensavers /usr/lib/xscreensaver/config
-}
-
-pkg_postinst() {
-       local XSCREENSAVER_CONF="${ROOT}/usr/lib/X11/app-defaults/XScreenSaver"
-
-       if [ -f ${XSCREENSAVER_CONF} ]; then
-               einfo "Adding Really Slick Screensavers to XScreenSaver"
-               sed -e '/*programs:/a\
-       GL:       \"Cyclone\"  cyclone --root     \\n\\\
-       GL:      \"Euphoria\"  euphoria --root    \\n\\\
-       GL:    \"Fieldlines\"  fieldlines --root  \\n\\\
-       GL:        \"Flocks\"  flocks --root      \\n\\\
-       GL:          \"Flux\"  flux --root        \\n\\\
-       GL:        \"Helios\"  helios --root      \\n\\\
-       GL:    \"Hyperspace\"  hyperspace --root  \\n\\\
-       GL:       \"Lattice\"  lattice --root     \\n\\\
-       GL:        \"Plasma\"  plasma --root      \\n\\\
-       GL:     \"Skyrocket\"  skyrocket --root   \\n\\\
-       GL:    \"Solarwinds\"  solarwinds --root  \\n\\\
-       GL:     \"Colorfire\"  colorfire --root   \\n\\\
-       GL:   \"Hufos Smoke\"  hufo_smoke --root  \\n\\\
-       GL:  \"Hufos Tunnel\"  hufo_tunnel --root \\n\\\
-       GL:    \"Sundancer2\"  sundancer2 --root  \\n\\\
-       GL:          \"BioF\"  biof --root        \\n\\\
-       GL:    \"MatrixView\"  matrixview --root  \\n\\\
-       GL:   \"Spirographx\"  spirographx --root \\n\\\
-       GL:   \"BusySpheres\"  busyspheres --root \\n\\' \
-               -i ${XSCREENSAVER_CONF}
-
-       else
-               einfo "Unable to add these to XScreenSaver configuration"
-               einfo "This should not happen. Please file a bug"
-       fi
-}
-
-pkg_postrm() {
-       local XSCREENSAVER_CONF="${ROOT}/usr/lib/X11/app-defaults/XScreenSaver"
-
-       has_version x11-misc/rss-glx && return 0
-       if [ -f ${XSCREENSAVER_CONF} ]; then
-               einfo "Removing Really Slick Screensavers from XScreenSaver configuration."
-               sed \
-                       -e '/\"Cyclone\"  cyclone/d' \
-                       -e '/\"Euphoria\"  euphoria/d' \
-                       -e '/\"Fieldlines\"  fieldlines/d' \
-                       -e '/\"Flocks\"  flocks/d' \
-                       -e '/\"Flux\"  flux/d' \
-                       -e '/\"Helios\"  helios/d' \
-                       -e '/\"Hyperspace\"  hyperspace/d' \
-                       -e '/\"Lattice\"  lattice/d' \
-                       -e '/\"Plasma\"  plasma/d' \
-                       -e '/\"Skyrocket\"  skyrocket/d' \
-                       -e '/\"Solarwinds\"  solarwinds/d' \
-                       -e '/\"Colorfire\"  colorfire/d' \
-                       -e '/\"Hufos Smoke\"  hufo_smoke/d' \
-                       -e '/\"Hufos Tunnel\"  hufo_tunnel/d' \
-                       -e '/\"Sundancer2\"  sundancer2/d' \
-                       -e '/\"BioF\"  biof/d' \
-                       -e '/\"MatrixView\"  matrixview/d' \
-                       -e '/\"Spirographx\"  spirographx/d' \
-                       -e '/\"BusySpheres\"  busyspheres/d' \
-                       -i ${XSCREENSAVER_CONF}
-       fi
-}
diff --git a/x11-misc/xscreensaver/files/digest-xscreensaver-5.00-r1 b/x11-misc/xscreensaver/files/digest-xscreensaver-5.00-r1
deleted file mode 100644 (file)
index a3b7450..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2c26877fb0acd508b9a726dce6a77f78 xscreensaver-5.00.tar.gz 5263478
-RMD160 7630ff42cfd24557cf1459902ddc6256004fc938 xscreensaver-5.00.tar.gz 5263478
-SHA256 976e888bead1185ce3116a92df2829f9fe93061d0539f5d8036ca0ddc016d80f xscreensaver-5.00.tar.gz 5263478
diff --git a/x11-misc/xscreensaver/xscreensaver-5.00-r1.ebuild b/x11-misc/xscreensaver/xscreensaver-5.00-r1.ebuild
deleted file mode 100644 (file)
index 186408f..0000000
+++ /dev/null
@@ -1,184 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xscreensaver/xscreensaver-5.00-r1.ebuild,v 1.7 2006/11/19 12:44:39 nelchael Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="1.4"
-
-inherit eutils flag-o-matic pam fixheadtails autotools
-
-IUSE="gnome jpeg insecure-savers new-login nls offensive opengl pam xinerama"
-
-DESCRIPTION="A modular screen saver and locker for the X Window System"
-SRC_URI="http://www.jwz.org/xscreensaver/${P}.tar.gz"
-HOMEPAGE="http://www.jwz.org/xscreensaver/"
-
-LICENSE="BSD"
-KEYWORDS="~alpha ~amd64 arm ~hppa ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-SLOT="0"
-
-RDEPEND="x11-libs/libXxf86misc
-       x11-apps/xwininfo
-       x11-apps/appres
-       media-libs/netpbm
-       >=sys-libs/zlib-1.1.4
-       >=dev-libs/libxml2-2.5
-       >=x11-libs/gtk+-2
-       >=gnome-base/libglade-1.99
-       >=dev-libs/glib-2
-       pam? ( virtual/pam )
-       jpeg? ( media-libs/jpeg )
-       opengl? ( virtual/opengl
-               >=media-libs/gle-3.0.1 )
-       xinerama? ( x11-libs/libXinerama )
-       !arm? ( new-login? ( gnome-base/gdm ) )"
-
-DEPEND="${RDEPEND}
-       x11-proto/xf86vidmodeproto
-       x11-proto/xextproto
-       x11-proto/scrnsaverproto
-       x11-proto/recordproto
-       x11-proto/xf86miscproto
-       sys-devel/bc
-       dev-util/pkgconfig
-       nls? ( sys-devel/gettext )
-       xinerama? ( x11-proto/xineramaproto )"
-
-# simple workaround for the flurry screensaver
-filter-flags -mabi=altivec
-filter-flags -maltivec
-append-flags -U__VEC__
-
-pkg_setup() {
-
-       if use arm && use new-login; then
-               ewarn "gnome-base/gdm is required for USE=\"new-login\", and is not"
-               ewarn "available for the arm platform. please disable this use flag"
-               die "new-login USE is not supported on arm"
-       fi
-
-}
-
-src_unpack() {
-
-       unpack "${A}"
-       cd "${S}"
-
-       # Bug fixes:
-       epatch "${FILESDIR}/${P}-gentoo.patch"
-
-       # Fix bug #143662:
-       # "xscreensaver-5.00 badly parse a float resource"
-       epatch "${FILESDIR}/${P}-get_float_resource.patch"
-
-       # disable not-safe-for-work xscreensavers
-       use offensive || epatch "${FILESDIR}/${P}-nsfw.patch"
-
-       eautoreconf
-
-       # change old head/tail to POSIX ones
-       ht_fix_all
-
-}
-
-src_compile() {
-
-       unset BC_ENV_ARGS
-       econf \
-               --with-hackdir=/usr/lib/misc/xscreensaver \
-               --with-configdir=/usr/share/xscreensaver/config \
-               --x-libraries=/usr/$(get_libdir) \
-               --x-includes=/usr/include \
-               --with-mit-ext \
-               --with-dpms-ext \
-               --with-xf86vmode-ext \
-               --with-xf86gamma-ext \
-               --with-proc-interrupts \
-               --with-xpm \
-               --with-xshm-ext \
-               --with-xdbe-ext \
-               --enable-locking \
-               --with-gtk \
-               --with-xml \
-               --without-kerberos \
-               $(use_with insecure-savers setuid-hacks) \
-               $(use_with new-login login-manager) \
-               $(use_with xinerama xinerama-ext) \
-               $(use_with pam) \
-               $(use_with opengl gl) $(use_with opengl gle) \
-               $(use_with jpeg) \
-               $(use_enable nls) \
-               || die "econf failed"
-
-       emake || die "emake failed"
-
-}
-
-src_install() {
-
-       [[ -n "${KDEDIR}" ]] && dodir "${KDEDIR}/bin"
-
-       make install_prefix="${D}" install || die "make install failed"
-
-       dodoc README
-
-       # install correctly in gnome, including info about configuration preferences
-       if use gnome ; then
-
-               dodir /usr/share/gnome/capplets
-               insinto /usr/share/gnome/capplets
-               doins driver/screensaver-properties.desktop
-
-               newicon "${S}/utils/images/logo-50.xpm" xscreensaver.xpm
-
-               dodir /usr/share/control-center-2.0/capplets
-               insinto /usr/share/control-center-2.0/capplets
-               newins "${FILESDIR}/desktop_entries/screensaver-properties.desktop"
-
-       fi
-
-       # Remove "extra" capplet
-       rm -f "${D}/usr/share/applications/gnome-screensaver-properties.desktop"
-
-       use pam && fperms 755 /usr/bin/xscreensaver
-       pamd_mimic_system xscreensaver auth
-
-       # Fix bug #135549:
-       rm -f "${D}/usr/share/xscreensaver/config/electricsheep.xml"
-       rm -f "${D}/usr/share/xscreensaver/config/fireflies.xml"
-       dodir /usr/share/man/man6x
-       mv "${D}/usr/share/man/man6/worm.6" \
-               "${D}/usr/share/man/man6x/worm.6x"
-
-}
-
-pkg_postinst() {
-
-       if ! use new-login; then
-               einfo
-               einfo "You have chosen to not use the new-login USE flag."
-               einfo "This is a new USE flag which enables individuals to"
-               einfo "create new logins when the screensaver is active,"
-               einfo "allowing others to use their account, even though the"
-               einfo "screen is locked to another account. If you want this"
-               einfo "feature, please recompile with USE=\"new-login\"."
-               einfo
-       fi
-
-       if use insecure-savers;then
-               ewarn
-               ewarn "You have chosen USE=insecure-savers. While upstream"
-               ewarn "has made every effort to make sure these savers do not"
-               ewarn "abuse their setuid root status, the possibilty exists that"
-               ewarn "someone will exploit xscreensaver and will be able to gain"
-               ewarn "root privileges. You have been warned."
-               ewarn
-       fi
-
-       ewarn
-       ewarn "In XScreenSaver 5.00 API was changed. All third party screen savers"
-       ewarn "need to be ported to the new API. Until then they will not work."
-       ewarn
-       epause
-
-}