dev-ros/turtlesim: eapi7
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 17:26:08 +0000 (19:26 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 17:30:58 +0000 (19:30 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/turtlesim/turtlesim-0.10.0.ebuild
dev-ros/turtlesim/turtlesim-9999.ebuild

index fcc2e65dc1f290ca8d00c0886d0d4ce60fc6c5b8..1f53e6c46ac3fa779be1ef3b77672aee242b866a 100644 (file)
@@ -1,12 +1,11 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 ROS_REPO_URI="https://github.com/ros/ros_tutorials"
 KEYWORDS="~amd64 ~arm"
 ROS_SUBDIR=${PN}
 CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/std_srvs dev-ros/geometry_msgs"
 
 inherit ros-catkin
@@ -26,7 +25,8 @@ RDEPEND="
        dev-ros/roscpp_serialization
        dev-ros/roslib
        dev-ros/rostime
+"
+DEPEND="${RDEPEND}
        dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
 "
-DEPEND="${RDEPEND}"
index e2e296b12f343bf8e92038c4fe75c6feef461544..1f53e6c46ac3fa779be1ef3b77672aee242b866a 100644 (file)
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 ROS_REPO_URI="https://github.com/ros/ros_tutorials"
 KEYWORDS="~amd64 ~arm"
 ROS_SUBDIR=${PN}
 CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/std_srvs dev-ros/geometry_msgs"
 
 inherit ros-catkin
@@ -26,7 +25,8 @@ RDEPEND="
        dev-ros/roscpp_serialization
        dev-ros/roslib
        dev-ros/rostime
+"
+DEPEND="${RDEPEND}
        dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
 "
-DEPEND="${RDEPEND}"