sci-mathematics/z3: Run tests
authorMichał Górny <mgorny@gentoo.org>
Thu, 13 Dec 2018 20:50:27 +0000 (21:50 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 13 Dec 2018 20:52:18 +0000 (21:52 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-mathematics/z3/z3-4.8.3.ebuild

index ea65ed84b8acc4c2259b1e54fbb894f85e9a613b..7c82aaa652f363f4830bac4da989d2f76f6a8c6d 100644 (file)
@@ -53,6 +53,13 @@ src_configure() {
        cmake-utils_src_configure
 }
 
+src_test() {
+       cmake-utils_src_make test-z3
+       set -- "${BUILD_DIR}"/test-z3 /a
+       echo "${@}" >&2
+       "${@}" || die
+}
+
 src_install() {
        local DOCS=( "README.md" "RELEASE_NOTES" )
        cmake-utils_src_install