dev-python/booleanOperations: Newer pyclipper needed, skip tests for now
authorPacho Ramos <pacho@gentoo.org>
Wed, 29 Apr 2020 17:10:13 +0000 (19:10 +0200)
committerPacho Ramos <pacho@gentoo.org>
Wed, 29 Apr 2020 17:10:36 +0000 (19:10 +0200)
Bug: https://bugs.gentoo.org/719882
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/booleanOperations/booleanOperations-0.9.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/booleanOperations/booleanOperations-0.9.0-r1.ebuild b/dev-python/booleanOperations/booleanOperations-0.9.0-r1.ebuild
new file mode 100644 (file)
index 0000000..8904255
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Boolean operations on paths"
+HOMEPAGE="https://github.com/typemytype/booleanOperations"
+SRC_URI="https://github.com/typemytype/booleanOperations/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+BDEPEND=""
+RDEPEND="${DEPEND}
+       >=dev-python/fonttools-4.0.2[${PYTHON_USEDEP}]
+       >=dev-python/pyclipper-1.1.0_p3[${PYTHON_USEDEP}]
+       dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests setup.py
+
+# tests need fontPens, that is not packaged
+RESTRICT="test"
+
+src_prepare() {
+       export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+       distutils-r1_src_prepare
+}