dev-java/jansi: Make use of java-pkg-simple and allow for compilation to go through...
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 18 Dec 2015 16:29:47 +0000 (16:29 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 18 Dec 2015 16:32:44 +0000 (16:32 +0000)
Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/jansi/jansi-1.5-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/jansi/jansi-1.5-r1.ebuild b/dev-java/jansi/jansi-1.5-r1.ebuild
new file mode 100644 (file)
index 0000000..9eb6c5e
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jansi is a small java library that allows you to use ANSI escape sequences in your console output"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/archive/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+
+CDEPEND="dev-java/jansi-native:0"
+
+DEPEND="${CDEPEND}
+       >=virtual/jdk-1.6"
+
+RDEPEND="${CDEPEND}
+       >=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_GENTOO_CLASSPATH="jansi-native"
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+       rm -rf src/test || die
+}