dev-libs/log4cpp: version bump.
authorBenda Xu <heroxbd@gentoo.org>
Sun, 13 Oct 2019 13:31:05 +0000 (21:31 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Sun, 13 Oct 2019 13:38:47 +0000 (21:38 +0800)
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
dev-libs/log4cpp/Manifest
dev-libs/log4cpp/log4cpp-1.1.3.ebuild [new file with mode: 0644]

index 5273c7eecda303df708e08d0e0dc3c3a6e6cb2d0..11d9fe1e8c7e202c463f7939b51904828342602c 100644 (file)
@@ -1 +1,2 @@
+DIST log4cpp-1.1.3.tar.gz 595639 BLAKE2B fc7d643aa70d739e38ec5aba127b4e760a47a064f4032690586c4698ec83a2b7f219d8476650d3bfc5e25563de0852869429ec45171233c6bd5c08b69476b169 SHA512 88e5e10bce8d7d6421c3dcf14aa25385159c4ae52becdc1f3666ab86e1ad3f633786d82afe398c517d4faaa57b3e7b7c0b524361d81c6b9040dbded5cecc19de
 DIST log4cpp-1.1.tar.gz 547676 BLAKE2B 3fee8e575b404215d308a0d6c72feef612dcfb9c881c97500937d1a94d1c435108a24ae1ad20f19cedb1613735c22a37354226699fe6cafbf6d23dcd12668271 SHA512 e1a723641c75a0b7f9ad2338134b327cd9a0a1bd67ff76bca726389ad76e8ba0ee5a95abe6f29e05a77980255dc08b0aa5c906395b0a0ad094994c9e450e3ecb
diff --git a/dev-libs/log4cpp/log4cpp-1.1.3.ebuild b/dev-libs/log4cpp/log4cpp-1.1.3.ebuild
new file mode 100644 (file)
index 0000000..3dbdf54
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C++ classes for flexible logging to files, syslog and other destinations"
+HOMEPAGE="http://log4cpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~ppc ~s390 ~x86"
+IUSE="doc static-libs test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+PATCHES=(
+       "${FILESDIR}"/1.0-doc_install_path.patch
+       "${FILESDIR}"/1.0-gcc43.patch
+       "${FILESDIR}"/1.0-asneeded.patch
+       "${FILESDIR}"/${PN}-1.1-cmath-fix.patch
+       "${FILESDIR}"/${PN}-1.1-automake-1.13.patch
+)
+
+S="${WORKDIR}/${PN}"
+
+MULTILIB_CHOST_TOOLS=(
+       /usr/bin/log4cpp-config
+)
+
+src_prepare() {
+       default
+
+       mv configure.{in,ac} || die
+
+       # Build tests conditionally
+       if ! use test; then
+               sed -i -e '/^SUBDIRS/s/ tests//' Makefile.am || die
+       fi
+
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} econf \
+               --without-idsa \
+               $(use_enable doc doxygen) \
+               $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+       einstalldocs
+
+       # package installs .pc files
+       find "${D}" -name '*.la' -delete || die
+}