sys-libs/tevent: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 17 Dec 2019 13:40:24 +0000 (14:40 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 17 Dec 2019 13:50:00 +0000 (14:50 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-libs/tevent/Manifest
sys-libs/tevent/tevent-0.9.38.ebuild [deleted file]

index 758102f7a4d8136b4202cef76cd0e88dc300e6d4..91e27943049919a351cf5ea51ec9dd75a021663a 100644 (file)
@@ -3,5 +3,4 @@ DIST tevent-0.10.1.tar.gz 804125 BLAKE2B bc124bbf509c0cbf148142ca26312fd74c3bae4
 DIST tevent-0.10.2.tar.gz 800731 BLAKE2B 5ea6b83378b04dbe1666432db0dbd4c0df2e6b0bf5ebcc8ec4ec9bdeb834efec75c87b2019dc78c691aba6c4f6467394101febd6010f106046a1fb8848e27405 SHA512 1da8f28898f35daab515892b880d1de601062cc3e2b2570cd62e6913df17b0195a05acb7b484c628cddc0eb8b0cde893105ede3feb32bc5764e7d25684f332ba
 DIST tevent-0.9.31.tar.gz 587784 BLAKE2B 0e562600ae8ba4dae194b1a28a020f5618b1566f65cf2b2f158cd44e6cb30c422086bd2ebfd65a03bc4d4b13de4ca833ff04ab1368255eb2181c148de3487214 SHA512 048e37a7f5d3b8e948215fdb909c9b6e94b915c9d4978a8e18c73c9d27d5b1f179c10d19ec90325f8250e7c177c28231ad116a2975caaa43312c383e75517258
 DIST tevent-0.9.37.tar.gz 603859 BLAKE2B 2210416b09c3f83cf68a9f686d1d582891cd22b4547eb0e5237288dca6a0b94619769060c541e0cfc3ccce79246b1140875109934e009015b8e04a31a94d6792 SHA512 5d4833403e1c2f2749f00a389e4757261a4f22cd3a67c906001b36a8b622cc68a38e86d4eb475848a2121ebba054a7e7dac7f486d9f2906a401c3cc97fb447f4
-DIST tevent-0.9.38.tar.gz 794856 BLAKE2B 1198de5e68cec39bac3931aa5c26ee26aa5fd713d9cbc72bd90d5dd9c787d617d17c57d8393a845800168452cd8092d38ddc480d3bbe176dfe364d6c9a211094 SHA512 f475a7b7c261368bd641992c8f657c081bbbe783535ff435a7b68f7749d0e5873d57d05cf6ce80a28ccc9f11033022d28e9ae357b03854109c2c279a003d2035
 DIST tevent-0.9.39.tar.gz 795796 BLAKE2B a352d2730f4d480f18559ac01b82354914ebf3ced0438bc6813e8cddc8e2ac1a5bcd867a00441cf243753daa299b6e61ad6328d5e3f7370483f01d468d7e2621 SHA512 72f48493aa3ef2efb78fa4e8cbeca8a66871e6835b51307ce08864ed0a778ccfd5f62d6768099f06680915375ee78c3b889514e247bcfe797889f16388c321b0
diff --git a/sys-libs/tevent/tevent-0.9.38.ebuild b/sys-libs/tevent/tevent-0.9.38.ebuild
deleted file mode 100644 (file)
index 624b563..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{5,6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit waf-utils multilib-minimal python-single-r1
-
-DESCRIPTION="Samba tevent library"
-HOMEPAGE="https://tevent.samba.org/"
-SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-linux"
-IUSE="elibc_glibc python"
-
-RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
-       >=sys-libs/talloc-2.1.15[${MULTILIB_USEDEP}]
-       python? ( ${PYTHON_DEPS} )"
-
-DEPEND="${RDEPEND}
-       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
-       elibc_glibc? (
-               net-libs/libtirpc[${MULTILIB_USEDEP}]
-               || (
-                       net-libs/rpcsvc-proto
-                       <sys-libs/glibc-2.26[rpc(+)]
-               )
-       )
-       ${PYTHON_DEPS}
-"
-# build system does not work with python3
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-RESTRICT="test"
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       default
-       multilib_copy_sources
-}
-
-multilib_src_configure() {
-       waf-utils_src_configure \
-               --bundled-libraries=NONE \
-               --builtin-libraries=NONE \
-               $(multilib_native_usex python '' '--disable-python')
-}
-
-multilib_src_compile() {
-       # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
-       unset MAKEOPTS
-       waf-utils_src_compile
-}
-
-multilib_src_install() {
-       waf-utils_src_install
-
-       multilib_is_native_abi && use python && python_domodule tevent.py
-}
-
-multilib_src_install_all() {
-       insinto /usr/include
-       doins tevent_internal.h
-}