sys-process/htop: Use slot operators for ncurses; drop old
authorJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 10:31:17 +0000 (12:31 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 10:31:24 +0000 (12:31 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sys-process/htop/Manifest
sys-process/htop/htop-1.0.2-r2.ebuild [deleted file]
sys-process/htop/htop-1.0.2.ebuild [deleted file]
sys-process/htop/htop-1.0.3.ebuild

index ce3f8d98bd556b30b5fc271279a02053add0fe31..c8d23ca124b38bcfddd9e00b9a383839d258a8b9 100644 (file)
@@ -1,2 +1 @@
-DIST htop-1.0.2.tar.gz 388499 SHA256 ee60657b044ece0df096c053060df7abf3cce3a568ab34d260049e6a37ccd8a1 SHA512 50ae0e8ace862520c01a707b3cf9a19591dc1081f6fc38c7fdccc81e36dd94b3cbe9db00cbb90f782c22d9b73f22526e24d04fad8368c6f2a7de0c58f9d92191 WHIRLPOOL 2766cfe1ea9c98d23c375e5a1c293c6d573d33cf7132e9aaa6ad0335a5f62976a8b8a8da6ede2f03bbadb31ac62e9d7ba5b35138a262dda73eb033afdf27b570
 DIST htop-1.0.3.tar.gz 399306 SHA256 055c57927f75847fdc222b5258b079a9542811a9dcf5421c615c7e17f55d1829 SHA512 4c5c784b093bcad06eb2e8d8bb215e14f6e838a3d47d8da8402344c270c1724f85d0bcde2899571ba5d0e5a02274a0c3390a76fed61785b2604b51351f08f232 WHIRLPOOL 14b8879210025aff9a1e098314a1b35d2bb6fcfaab42b95670e3726c61d471b1618486e6fc3dbbc97043e85f9a22196d97e676f3b2dd98250326be8527bdebbe
diff --git a/sys-process/htop/htop-1.0.2-r2.ebuild b/sys-process/htop/htop-1.0.2-r2.ebuild
deleted file mode 100644 (file)
index 3ad8378..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils linux-info python-any-r1
-
-DESCRIPTION="interactive process viewer"
-HOMEPAGE="http://htop.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
-
-RDEPEND="sys-libs/ncurses[unicode?]"
-DEPEND="${RDEPEND}"
-
-DOCS=( ChangeLog README )
-
-CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-
-# config.h problems
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-pkg_setup() {
-       if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
-               echo
-               eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
-               eerror "To mount it, type:"
-               [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
-               eerror "mount -t linprocfs none /compat/linux/proc"
-               eerror "Alternatively, place this information into /etc/fstab"
-               echo
-               die "htop needs /compat/linux/proc mounted"
-       fi
-
-       if ! has_version sys-process/lsof; then
-               ewarn "To use lsof features in htop(what processes are accessing"
-               ewarn "what files), you must have sys-process/lsof installed."
-       fi
-       python-any-r1_pkg_setup
-       linux-info_pkg_setup
-}
-
-PATCHES=(
-       "${FILESDIR}"/${P}-tinfo.patch
-       "${FILESDIR}"/${P}-process.patch
-       "${FILESDIR}"/${P}-out-of-src.patch
-)
-
-src_prepare() {
-       rm missing || die
-       sed \
-               -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
-               -i scripts/MakeHeader.py || die
-       autotools-utils_src_prepare
-}
-
-src_configure() {
-       [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
-
-       local myeconfargs=()
-
-       use kernel_FreeBSD && myeconfargs+=( --with-proc=/compat/linux/proc )
-
-       myeconfargs+=(
-               $(use_enable openvz)
-               $(use_enable kernel_linux cgroup)
-               $(use_enable vserver)
-               $(use_enable unicode)
-               --enable-taskstats
-               )
-       autotools-utils_src_configure
-}
diff --git a/sys-process/htop/htop-1.0.2.ebuild b/sys-process/htop/htop-1.0.2.ebuild
deleted file mode 100644 (file)
index 28e1a57..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-DESCRIPTION="interactive process viewer"
-HOMEPAGE="http://htop.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
-
-RDEPEND="sys-libs/ncurses[unicode?]"
-DEPEND="${RDEPEND}"
-
-DOCS=( ChangeLog README )
-
-pkg_setup() {
-       if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
-               echo
-               eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
-               eerror "To mount it, type:"
-               [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
-               eerror "mount -t linprocfs none /compat/linux/proc"
-               eerror "Alternatively, place this information into /etc/fstab"
-               echo
-               die "htop needs /compat/linux/proc mounted"
-       fi
-
-       if ! has_version sys-process/lsof; then
-               ewarn "To use lsof features in htop(what processes are accessing"
-               ewarn "what files), you must have sys-process/lsof installed."
-       fi
-}
-
-src_prepare() {
-       sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
-               scripts/MakeHeader.py || die
-}
-
-src_configure() {
-       [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
-
-       local myconf=''
-
-       use kernel_FreeBSD && myconf="${myconf} --with-proc=/compat/linux/proc"
-
-       econf \
-               $(use_enable openvz) \
-               $(use_enable kernel_linux cgroup) \
-               $(use_enable vserver) \
-               $(use_enable unicode) \
-               --enable-taskstats \
-               ${myconf}
-}
index a0b4ab8a3891337a6497bf1ec1088caa4df71a28..6a433f5340d4a281da07ecaf999e8796924e65ca 100644 (file)
@@ -19,7 +19,7 @@ SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
 IUSE="kernel_FreeBSD kernel_linux oom openvz unicode vserver"
 
-RDEPEND="sys-libs/ncurses[unicode?]"
+RDEPEND="sys-libs/ncurses:5=[unicode?]"
 DEPEND="${RDEPEND}
        ${PYTHON_DEPS}
        virtual/pkgconfig"