shutdown now goes into single user mode by default, #158615.
authorRoy Marples <uberlord@gentoo.org>
Thu, 21 Dec 2006 10:48:03 +0000 (10:48 +0000)
committerRoy Marples <uberlord@gentoo.org>
Thu, 21 Dec 2006 10:48:03 +0000 (10:48 +0000)
Package-Manager: portage-2.1.2_rc3-r9

sys-apps/sysvinit/ChangeLog
sys-apps/sysvinit/files/digest-sysvinit-2.86-r7 [new file with mode: 0644]
sys-apps/sysvinit/files/sysvinit-2.86-shutdown-single.patch [new file with mode: 0644]
sys-apps/sysvinit/sysvinit-2.86-r7.ebuild [new file with mode: 0644]

index 90e0dc6d722f57bea324f4e528249105cc9aded1..721383f2ce0ba6cf2a0e152fa5674337aab668a7 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-apps/sysvinit
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.35 2006/12/12 11:11:10 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.36 2006/12/21 10:48:03 uberlord Exp $
+
+*sysvinit-2.86-r7 (21 Dec 2006)
+
+  21 Dec 2006; Roy Marples <uberlord@gentoo.org>
+  +files/sysvinit-2.86-shutdown-single.patch, +sysvinit-2.86-r7.ebuild:
+  shutdown now goes into single user mode by default, #158615.
 
   12 Dec 2006; Roy Marples <uberlord@gentoo.org> sysvinit-2.86-r6.ebuild:
   Move sysvinit-2.86-r6 to ~ARCH.
diff --git a/sys-apps/sysvinit/files/digest-sysvinit-2.86-r7 b/sys-apps/sysvinit/files/digest-sysvinit-2.86-r7
new file mode 100644 (file)
index 0000000..7fc9a56
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 650af823f937d386e81520b1741d4d45 sysvinit-2.86-kexec.patch 4139
+RMD160 5f8e9ccd3a39701cf47a1a541c78a4be971d46fc sysvinit-2.86-kexec.patch 4139
+SHA256 936245ef3060939bec3099efc006009336b3672422c1de41983b277ab5ddac47 sysvinit-2.86-kexec.patch 4139
+MD5 7d5d61c026122ab791ac04c8a84db967 sysvinit-2.86.tar.gz 99009
+RMD160 46587ab51390b5c8cd3179a3690f86efdbe9b4b9 sysvinit-2.86.tar.gz 99009
+SHA256 035f98fae17d9cff002993c564ccc83dc4ed136127172caeff872b6abdb679d8 sysvinit-2.86.tar.gz 99009
diff --git a/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-single.patch b/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-single.patch
new file mode 100644 (file)
index 0000000..07f434e
--- /dev/null
@@ -0,0 +1,38 @@
+This patch makes shutdown use the Single User runlevel by default so
+the gettys are shutdown too.
+
+Roy Marples <uberlord@gentoo.org>
+
+diff -ur sysvinit-2.86.orig/man/shutdown.8 sysvinit-2.86/man/shutdown.8
+--- sysvinit-2.86.orig/man/shutdown.8  2006-12-21 10:16:37.000000000 +0000
++++ sysvinit-2.86/man/shutdown.8       2006-12-21 10:19:51.000000000 +0000
+@@ -27,7 +27,7 @@
+ \fBshutdown\fP does its job by signalling the \fBinit\fP process, 
+ asking it to change the runlevel.
+ Runlevel \fB0\fP is used to halt the system, runlevel \fB6\fP is used
+-to reboot the system, and runlevel \fB1\fP is used to put to system into
++to reboot the system, and runlevel \fBS\fP is used to put to system into
+ a state where administrative tasks can be performed; this is the default
+ if neither the \fI-h\fP or \fI-r\fP flag is given to \fBshutdown\fP.
+ To see which actions are taken on halt or reboot see the appropriate
+diff -ur sysvinit-2.86.orig/src/shutdown.c sysvinit-2.86/src/shutdown.c
+--- sysvinit-2.86.orig/src/shutdown.c  2006-12-21 10:16:37.000000000 +0000
++++ sysvinit-2.86/src/shutdown.c       2006-12-21 10:21:03.000000000 +0000
+@@ -463,7 +463,7 @@
+               usage();
+               exit(1);
+       }
+-      strcpy(down_level, "1");
++      strcpy(down_level, "S");
+       halttype = NULL;
+       /* Process the options. */
+@@ -636,6 +636,8 @@
+                       strcpy(newstate, "for reboot");
+                       break;
+               case '1':
++              case 'S':
++              case 's':
+                       strcpy(newstate, "to maintenance mode");
+                       break;
+               default:
diff --git a/sys-apps/sysvinit/sysvinit-2.86-r7.ebuild b/sys-apps/sysvinit/sysvinit-2.86-r7.ebuild
new file mode 100644 (file)
index 0000000..67a8fc5
--- /dev/null
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86-r7.ebuild,v 1.1 2006/12/21 10:48:03 uberlord Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="/sbin/init - parent of all processes"
+HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
+SRC_URI="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
+       ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
+       http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux ibm static"
+
+RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
+DEPEND="${RDEPEND}
+       virtual/os-headers"
+
+src_unpack() {
+       unpack ${P}.tar.gz
+       cd "${S}"
+       cp "${FILESDIR}"/change_console.{c,8} src/ || die
+       epatch "${FILESDIR}"/${P}-docs.patch
+       epatch "${FILESDIR}"/${P}-shutdown-usage.patch
+       epatch "${FILESDIR}"/sysvinit-2.86-off-by-one.patch
+       epatch "${DISTDIR}"/sysvinit-2.86-kexec.patch
+       #epatch "${FILESDIR}"/sysvinit-2.86-POSIX-1003.1e.patch #5818
+       epatch "${FILESDIR}"/sysvinit-2.86-execl.patch
+       epatch "${FILESDIR}"/sysvinit-2.86-utmp-64bit.patch
+       epatch "${FILESDIR}/${P}"-shutdown-single.patch
+       cd src
+       epatch "${FILESDIR}"/${PV}-gentoo.patch
+       use selinux && epatch "${FILESDIR}"/${PV}-selinux-1.patch
+
+       # Mung inittab for specific architectures
+       cd "${WORKDIR}"
+       cp "${FILESDIR}"/inittab . || die "cp inittab"
+       local insert=""
+       if use ibm ; then
+               insert="#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
+               insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
+       fi
+       use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
+       use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
+       (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
+       [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
+}
+
+src_compile() {
+       use static && append-ldflags -static
+
+       # Note: The LCRYPT define below overrides the test in
+       # sysvinit's Makefile.  This is because sulogin must be linked
+       # to libcrypt in any case, but when building stage2 in
+       # catalyst, /usr/lib/libcrypt.a isn't available.  In truth
+       # this doesn't change how sulogin is built since ld would use
+       # the shared obj by default anyway!  The other option is to
+       # refrain from building sulogin, but that isn't a good option.
+       # (09 Jul 2004 agriffis)
+       emake -C src \
+               CC="$(tc-getCC)" \
+               DISTRO="Gentoo" \
+               LCRYPT="-lcrypt" \
+               all change_console \
+               || die
+}
+
+src_install() {
+       dodoc README doc/*
+
+       cd src
+       make install DISTRO="Gentoo" ROOT="${D}" || die "make install"
+
+       into /
+       dosbin change_console || die
+       doman change_console.8
+
+       insinto /etc
+       doins "${WORKDIR}"/inittab || die "inittab"
+
+       doinitd "${FILESDIR}"/{reboot,shutdown}.sh || die
+}
+
+pkg_postinst() {
+       # Reload init to fix unmounting problems of / on next reboot.
+       # This is really needed, as without the new version of init cause init
+       # not to quit properly on reboot, and causes a fsck of / on next reboot.
+       if [[ ${ROOT} == / ]] ; then
+               # Do not return an error if this fails
+               /sbin/telinit U &>/dev/null
+       fi
+}